close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 16 months ago

Closed 16 months ago

Last modified 12 months ago

#418 closed bug (fixed)

Bug when renaming Directory name

Reported by: opiopi Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9
Component: mail indexing Version: 2.8p1
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

when changing a folder's path the global .folders file will be immediately saved to make the change persistent.

Description

If i rename a directory (use Edit.. in the folderlist and change the "Directory name") all seems to work fine.
If i quit YAM and start again then YAM creates the old folder again which is of course empty.
The renamed folder with all mails are still exists in the YAM/Folders/... Directory.

The cause ist that after renaming a folder the ".folder" contain still the old name.
YAM should be so smart and change the ".folder" file so that it contain the new name after renaming.

Used Version:
YAM 2.9-dev (04.09.2013)
Copyright (C) 2000-2013 YAM Open Source Team [OS3/m68k, r7024]

My System is still a A2000 - AOS 3.9 BB2

Attachments (0)

Change History (4)

comment:1 Changed 16 months ago by tboeckel

  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Status changed from new to assigned

comment:2 Changed 16 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7027]) * mui/FolderEditWindow.c: changing a folder's path will now save the global .folders file again to make the change persistent. This closes #418.

comment:3 Changed 12 months ago by damato

  • Release Notes modified (diff)

comment:4 Changed 12 months ago by damato

  • Version changed from nightly build to 2.8p1

Add Comment

Modify Ticket

Action
as closed The owner will remain tboeckel.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter)
  • Thore Böckelmann(Owner, Participant)