close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 10 months ago

Closed 10 months ago

Last modified 7 months ago

#431 closed bug (fixed)

GR/DSI when clicking on SendNow or SendLater on write window

Reported by: javierdlr Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9
Component: user interface Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed a crash bug when trying to send a mail after it had been autosaved in the drafts folder.

Description

Summary

I get a GR/DSI (NListtree.mcc) everytime I click on SendLater or SendNow buttons on write window.

Steps to reproduce

  1. Open a new mail, write something and click on SendNow or SendLater on write window. 2.

Expected results

Send message

Actual results

GR/DSI

Regression

Notes

After cold reboot/reset message is in OUTGOING drawer, clicking SEND button from main YAM window sends messages without problems.

Attachments (3)

Crashlog_YAM_2013-09-23_11-08-32.txt (11.0 KB) - added by javierdlr 10 months ago.
GR/DSI on write window when clicking SendLater/SendNow button (1)
Crashlog_YAM_2013-09-23_00-11-13.txt (11.1 KB) - added by javierdlr 10 months ago.
GR/DSI on write window when clicking SendLater/SendNow button (2)
Crashlog_YAM_2013-09-23_23-58-05.txt (25.7 KB) - added by javierdlr 10 months ago.
Another GR/DSI (under AOS4.1 update6 "plain")

Download all attachments as: .zip

Change History (9)

Changed 10 months ago by javierdlr

GR/DSI on write window when clicking SendLater/SendNow button (1)

Changed 10 months ago by javierdlr

GR/DSI on write window when clicking SendLater/SendNow button (2)

comment:1 Changed 10 months ago by tboeckel

  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Status changed from new to assigned

Which nightly build exactly is crashing for you? There have been lots of changes to the internal mail handling recently and so far I am not able to reproduce this issue using the latest nightly build (23-Sep-2013).

comment:2 Changed 10 months ago by javierdlr

With 23.09.2013. Will go to check with previous versions to see with was the first one.
Using OS4.1 update6 and latest beta components.
Will try with OS4.1 update6 and post here results.

comment:3 follow-up: Changed 10 months ago by javierdlr

Ok, try this:
-Start a new message (I have autosave every 2 minutes)
-Wait unitl it gets copied/backuped into drafts folder.

It seems I get the GR/DSI when message is on draft folder. Hope it helps.

Changed 10 months ago by javierdlr

Another GR/DSI (under AOS4.1 update6 "plain")

comment:4 in reply to: ↑ 3 Changed 10 months ago by tboeckel

Replying to javierdlr:

Ok, try this:
-Start a new message (I have autosave every 2 minutes)
-Wait unitl it gets copied/backuped into drafts folder.

It seems I get the GR/DSI when message is on draft folder. Hope it helps.

Yes, this is the bit of information that was missing before. Now YAM is crashing for me, too. I will see what is causing this.

comment:5 Changed 10 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7107]) * mui/WriteWindow.c, YAM_MA.c, YAM_UT.c: erase the mail's folder pointer after removing it from a folder to avoid accessing this pointer after the mail has been freed. This closes #431.

comment:6 Changed 7 months ago by damato

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Javier de las Rivas(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)