close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 15 months ago

Last modified 7 months ago

#432 reopened bug

Accents not show correctly in mails

Reported by: rmsyam Owned by: tboeckel
Priority: low Milestone: YAM future release
Component: MIME handling Version: nightly build
Severity: major Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Summary

When reading mails, the accents are not shown correctly but get replaced by a "?"

Steps to reproduce

  1. simply open a mail 2.

Expected results

caracters like éàè as well as apostrophs should be shown like this

Actual results

these caracters get replaced by ? or other caracter combinations

Regression

Notes

Attachments (1)

example.eml (856 bytes) - added by tboeckel 14 months ago.
Example mail with two parts, plain text being encoded wrong

Download all attachments as: .zip

Change History (9)

comment:1 Changed 15 months ago by tboeckel

  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Status changed from new to assigned

comment:2 Changed 15 months ago by tboeckel

Having looked at the example mails that Christoph has sent to me it becomes obvious that this is not a bug in YAM, but a bug in the mail client the original sender uses. The mail consists of a normal text part and an alternative HTML part. According to the headers both parts are encoded as UTF8. While this is true for the HTML part it is wrong for the plain text part. The accented characters are encoded in the single byte Windows-1252 (guessed) charset, but definitely not in the multibyte UTF8 charset. This is why these characters are converted to "?", because codesets.library is not able to find a suitable replacement for them.

This effect is also visible in other mail clients like Thunderbird when the text display is switched from "original HTML" to "plain text".

comment:3 Changed 15 months ago by damato

  • Resolution set to invalid
  • Status changed from assigned to closed

comment:4 Changed 14 months ago by tboeckel

  • Resolution invalid deleted
  • Status changed from closed to reopened

I must add that YAM should be improved to be able to show all mail parts. This will make it possible to show the affected mails with correct accents by showing the HTML part converted to plain text. Currently this is not possible even when setting the option "LetterPart" in the hidden section to something else than "1".

Unfortunately I cannot attach files at the moment (bug in trac), hence I include a modified example mail inline. This mail perfectly shows that the HTML part is correctly encoded as UTF8, while the plain text part is encoded as Windows-1252 although the header tells it is UTF8, too. Hence YAM will show wrong characters.

From: "foo@…" <foo@…>
To: blafasel@…
Subject: =?UTF-8?Q?_Plong=C3=A9e_en_octobre_2013?=
MIME-Version: 1.0
Content-Type: multipart/mixed;

boundary="----=_Part_4987_30147052.1379848431650"


Content-Type: multipart/alternative;

boundary="----=_Part_4986_29142062.1379848431650"


Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Just some wrong encoded example words
r=E9servation
? 1.000
d=E9jeuner
plong=E9es


Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Just some correct encoded example words
r=C3=A9servation
=E2=82=AC 1.000
d=C3=A9jeuner
plong=C3=A9es



comment:5 Changed 14 months ago by tboeckel

  • Component changed from undefined to MIME handling
  • Milestone changed from YAM 2.9 to YAM future release

Changed 14 months ago by tboeckel

Example mail with two parts, plain text being encoded wrong

comment:6 Changed 8 months ago by tboeckel

  • OS Platform set to undefined

Ticket #557 contains a full example with exactly the same wrongly encoded plain text part while the HTML part is correctly encoded.

comment:7 Changed 8 months ago by tboeckel

  • OS Platform changed from undefined to All

comment:8 Changed 7 months ago by damato

  • Priority changed from undecided to low

Add Comment

Modify Ticket

Action
as reopened The owner will remain tboeckel.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter)
  • Thore Böckelmann(Owner, Participant)