close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 13 months ago

Closed 13 months ago

Last modified 10 months ago

#433 closed bug (fixed)

Crash when quiting YAM

Reported by: rmsyam Owned by:
Priority: undecided Milestone: YAM 2.9
Component: undefined Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed a crash bug when quitting YAM

Description

Summary

Not every time but often, YAM crashes when quiting. Everything is blocked, a reset has to be done.

Steps to reproduce

  1. Quit 2.

Expected results

Actual results

Regression

Notes

Attachments (3)

yam_log.lha (938.2 KB) - added by rmsyam 13 months ago.
log_24-09-13.lha (33.1 KB) - added by rmsyam 13 months ago.
yam_log.2.lha (2.9 KB) - added by rmsyam 13 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 months ago by tboeckel

  • Milestone set to YAM 2.9

Did YAM really crash while producing the attached log file? According to the log YAM successfully ran till its termination and did NOT crash inbetween.

comment:2 Changed 13 months ago by rmsyam

well no i must admit that this time I did not get any log data in MorphOS's log, but what happens for sure is that everything is blocked, YAM, Ambient, no icons are selectable anymore, etc. Only way is to reset via the button the machine! I send you another, new log.

Changed 13 months ago by rmsyam

comment:3 Changed 13 months ago by rmsyam

Here another MorphOS log file because YAM didn't wirte the simple log to my hd when it crashed.
I used: setenv yamdebug, file:pm3work:yam.log

Changed 13 months ago by rmsyam

comment:4 Changed 13 months ago by rmsyam

here another log file because YAM crashed again while trying to send a mail.

Changed 13 months ago by rmsyam

comment:5 Changed 13 months ago by tboeckel

Please don't mix crashes in totally different situations within one ticket. This ticket is about a crash when quitting YAM, not when downloading mails.

comment:6 Changed 13 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from new to closed

(In [7098]) * mui/MainFolderListtree.c: don't try to close the folder edit window during OM_DISPOSE, but just close it if it exists. Pushing the dispose method might let YAM try to dispose the window twice later on. This closes #433.

comment:7 Changed 13 months ago by tboeckel

(In [7102]) * mui/YAMApplication.c: fixed the broken address cache saving. This refs #433.

comment:8 Changed 13 months ago by tboeckel

(In [7103]) * YAM.c, mui/MainFolderListtree.c: reworked the folder edit window disposing once again to be really bullet proof. This refs #433.

comment:9 Changed 10 months ago by damato

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter, Participant)