close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 10 months ago

Closed 10 months ago

Last modified 7 months ago

#435 closed bug (fixed)

When hitting send, YAM crashes ans the system also

Reported by: rmsyam Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9
Component: undefined Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed a crash bug when trying to send a mail.

Description

Summary

When hitting send, YAM crashes and also the system completly though not every time!

Steps to reproduce

  1. writing a mail and hitting Send

2.

Expected results

Actual results

Regression

Notes

Attachments (7)

log_25-09-13 (693.2 KB) - added by rmsyam 10 months ago.
log_25-09-13.2 (253.9 KB) - added by rmsyam 10 months ago.
log_25-09-13.3 (252.9 KB) - added by rmsyam 10 months ago.
yam.log (18.6 KB) - added by rmsyam 10 months ago.
log_25-09-13.4 (660.5 KB) - added by rmsyam 10 months ago.
yam.2.log (20.8 KB) - added by rmsyam 10 months ago.
log_25-09-13.5 (292.0 KB) - added by rmsyam 10 months ago.

Download all attachments as: .zip

Change History (16)

Changed 10 months ago by rmsyam

comment:1 Changed 10 months ago by rmsyam

Here another log file, this was done when hitting send BUT this time the mail was send and the system did not crash!

Changed 10 months ago by rmsyam

comment:2 Changed 10 months ago by rmsyam

And here again 2 log files, one from YAM which is not complete as YAM crashes the system and the 2nd is from MorphOS system. Perhaps they help!

Changed 10 months ago by rmsyam

Changed 10 months ago by rmsyam

comment:3 Changed 10 months ago by rmsyam

and antoher (last) 2 log files. I have to stop because YAM crashes here on nearly every attempt to send a mail and even when viewing...

Changed 10 months ago by rmsyam

Changed 10 months ago by rmsyam

comment:4 Changed 10 months ago by rmsyam

Here a log, where YAM did send the mail but I got hits as soon as I hit send. Yam did not crash neihter did the system.

Changed 10 months ago by rmsyam

comment:5 Changed 10 months ago by tboeckel

(In [7113]) * YAM_MA.c, mui/WriteWindow.c: artifically increase and decrease the mail's reference counter before it is moved to another folder to prevent it from being freed too early when one of its referencing mail nodes is freed. This refs #429 and refs #435.

comment:6 Changed 10 months ago by tboeckel

  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Status changed from new to assigned

comment:7 Changed 10 months ago by rmsyam

It seems that YAM as of nigthly build from today works correctly! At least it doesn't crash, neither does it crash the system anymore and no hits in log. Many thanks

comment:8 Changed 10 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

That's good to hear. I'll close this ticket for the moment. Please reopen it again if this crash should happen again.

comment:9 Changed 7 months ago by damato

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)