close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 14 months ago

Closed 14 months ago

Last modified 11 months ago

#438 closed bug (fixed)

Crash when selecting "Send later"

Reported by: rmsyam Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9
Component: undefined Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed a crash bug caused by freeing the same mail pointer twice.

Description

Summary

Write or edit a mail and hit "Send later"
This creates an emtpy line in Drafts. After an "update index" the line hase an e-mail address, and a subject and date.

Steps to reproduce

  1. edit a mail and hit send later
  2. open this mail again to edit and hit again send later then YAM crashes

Expected results

Actual results

Regression

Notes

Attachments (8)

log_04-10-13 (519.9 KB) - added by rmsyam 14 months ago.
MorphOS.log (1.3 KB) - added by rmsyam 14 months ago.
log_07-10-13 (257.4 KB) - added by rmsyam 14 months ago.
ScreenGrab.png (1.8 MB) - added by rmsyam 14 months ago.
ScreenGrab.2.png (2.1 MB) - added by rmsyam 14 months ago.
YAM 2.9-dev - User Christoph Poelzl.png (75.1 KB) - added by rmsyam 14 months ago.
log_07-10-13.2 (27.3 KB) - added by rmsyam 14 months ago.
MorphOS.2.log (1.4 KB) - added by rmsyam 14 months ago.

Download all attachments as: .zip

Change History (17)

Changed 14 months ago by rmsyam

comment:1 Changed 14 months ago by rmsyam

I send you 2 more log files as well as a screengrab where you can see the error message from YAM and also that the e-mail line in Drafts is emtpy. I already assure you that there is enough space and the folder exists!

Changed 14 months ago by rmsyam

Changed 14 months ago by rmsyam

Changed 14 months ago by rmsyam

comment:2 Changed 14 months ago by rmsyam

Following the above and after a reset there is still a file in Drafts, please see the screengrab. When I then try to read it, I get an error message that the file does not exists. When I then do an update index on the Drafts folder everything shows up, e-mail address, subject... and I can read the e-mail.

Changed 14 months ago by rmsyam

Changed 14 months ago by rmsyam

comment:3 Changed 14 months ago by tboeckel

It seems there is some kind of memory trashing happening, because the logs point to one of YAM's memory freeing functions and the system logs tells something about a wrong size when freeing memory.

Unfortunately I am not able to reproduce this issue, no matter what I do. Could you please create a simple log using the debug version. This will include error messages about duplicate freeing attempts without any further options. At least this is the only thing I can think of right now.

Does this happen always when sending a mail? Or is this restricted to replying to a mail?

comment:4 Changed 14 months ago by rmsyam

Please find enclosed the new log's, one from YAM debug and also the MorphOS one.

I'm not sure if it has something to do with new or reply... to me it has rather to do with the mail getting saved in drafts...

Changed 14 months ago by rmsyam

Changed 14 months ago by rmsyam

comment:5 Changed 14 months ago by tboeckel

  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Status changed from new to assigned

I think I found a situation in which a mail could be freed twice. Perhaps the next nightly build fixes this issue. If it crashes nevertheless, then please provide a MAIL debug log.

comment:6 Changed 14 months ago by tboeckel

(In [7131]) * mui/WriteWindow.c: fixed a possible duplicate freeing of mails when saving a draft mail. This refs #438.

comment:7 follow-up: Changed 14 months ago by rmsyam

Working one day without problems now! I think this bug is solved.

comment:8 in reply to: ↑ 7 Changed 14 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to rmsyam:

Working one day without problems now! I think this bug is solved.

Hooray! :)
Please reopen this ticket if this crash happens again.

comment:9 Changed 11 months ago by damato

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)