close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 10 months ago

Closed 4 months ago

#440 closed bug (fixed)

Upper right main YAM window showing "empty" square

Reported by: javierdlr Owned by:
Priority: normal Milestone: YAM 2.9p1
Component: foreign component Version: nightly build
Severity: major Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

Not always, but sometimes, when I click on GET button, and seems when FILTERING new mails on the upper right corner it shows/paints an "empty" square, hidding some toolbar buttons.

IIRC it only shows when I have MUNGE option (os4_commandline=debuglevel=4 MUNGE
)

Please can you enlight me how to help to track this strange "bug"?
Ex. Using YAM.debug and setting XXXX DebugEnvarc. TIA

Steps to reproduce

  1. CLick on GET button to recieve mails and auto filtering is on. 2.

Expected results

Actual results

Regression

Notes

Attachments (8)

sgrab001.png (30.3 KB) - added by javierdlr 10 months ago.
Upper rright corner showing "empty" square (hidding some buttons)
sgrab001.2.png (130.0 KB) - added by javierdlr 10 months ago.
Same image, but without color reducing
sgrab002.png (115.3 KB) - added by tboeckel 9 months ago.
Screenshot of special colored version
yam_color_hspace.lha (1.2 MB) - added by tboeckel 9 months ago.
original HSpace object
yam_color_text.lha (1.2 MB) - added by tboeckel 9 months ago.
empty text object instead of HSpace
sgrab000_HSPACE.png (117.4 KB) - added by javierdlr 8 months ago.
YAM.hspace showing rectangle (in grey)
sgrab000_TEXT.png (115.8 KB) - added by javierdlr 8 months ago.
YAM.text version
YAM_RectangleBug.prefs (86 bytes) - added by javierdlr 4 months ago.
MUI default prefs. Only changed GAUGE settings

Download all attachments as: .zip

Change History (36)

comment:1 Changed 45 years ago by javierdlr

  • Status changed from pending to new

Changed 10 months ago by javierdlr

Upper rright corner showing "empty" square (hidding some buttons)

comment:1 Changed 10 months ago by tboeckel

So far I have never seen anything similar on my systems. Did you notice the empty window title bar? It should show something like "YAM 2.9-dev - User: your name".

The problem is, unless there isn't a crash happening it is quite hard, if not impossible, to spot the exact location or reason of this graphical distorsion.

Which MUI version are you using?

Changed 10 months ago by javierdlr

Same image, but without color reducing

comment:2 Changed 10 months ago by javierdlr

Ups, my foult reduced colors to upload image/grab. Reuploaded with "full" colors, sorry.

MUI 4 Versión:20.6038 (svn r2770).

No, but it happens here only with MUNGE option enabled. I'll continue testing new dev versions, and see if there is some kind of path to reproduce. TIA

comment:3 follow-up: Changed 9 months ago by javierdlr

Seems happens in the STATUS BAR, if it's disabled no problems (no empty square hidding icons/part_of_the_main_window).

Fontsize problem? (Localized) strings too long?

comment:4 in reply to: ↑ 3 Changed 9 months ago by tboeckel

Replying to javierdlr:

Seems happens in the STATUS BAR, if it's disabled no problems (no empty square hidding icons/part_of_the_main_window).

Fontsize problem? (Localized) strings too long?

I doubt it is either of these. YAM uses the MUI standard fonts (i.e. big, tiny, normal) and does absolutely nothing fancy for the affected group. I am running YAM myself on small screens (640x480, 800x600) and larger screens (1280x1024) but never have seen this effect myself. Too long strings are either truncated or cause an object to be hidden automatically.

I really have no clue which object might be causing this effect and why.

I can offer you to build a special version with some artifical coloring of the individual objects to make it more obvious which object is causing the effect.

You need AmigaOS4 binaries, correct?

comment:5 Changed 9 months ago by javierdlr

Yes you're correct my system is SAM3460ex with AOS4.1beta.
I'm going away for a few days. So until 23rd I can't test anything.
TIA

comment:6 Changed 9 months ago by javierdlr

opps my PM is jabierdlrATgmail.com

comment:7 Changed 9 months ago by tboeckel

Special version has been sent privately. These are the special background colors used for debugging purposes:

set(data->TX_FOLDER, MUIA_Background, "rff0000");
set(data->TX_FINFO, MUIA_Background, "r00ff00");
set(data->GA_GROUP, MUIA_Background, "r0000ff");
set(data->GA_LABEL, MUIA_Background, "rffff00");
set(data->GA_INFO, MUIA_Background, "r00ffff");
set(data->TX_INFO, MUIA_Background, "rff00ff");

comment:8 follow-up: Changed 9 months ago by javierdlr

erm, sorry to bother, but what email did you use? Haven't recieved nothing yet!
Or is somehow attached here in YAM's web/forum/..?

comment:9 in reply to: ↑ 8 Changed 9 months ago by tboeckel

Replying to javierdlr:

erm, sorry to bother, but what email did you use? Haven't recieved nothing yet!
Or is somehow attached here in YAM's web/forum/..?

Sorry, my crappy LTE internet connection didn't allow me to send out the mail yesterday. It is on its way now.

comment:10 Changed 9 months ago by tboeckel

Does this effect happen with MUI 3.9, too, or with MUI4 only?

comment:11 follow-up: Changed 9 months ago by javierdlr

Testing with MUI3.9 and no problems so far. Let me test it a few more days and will post here results. TIA.

Changed 9 months ago by tboeckel

Screenshot of special colored version

Changed 9 months ago by tboeckel

original HSpace object

Changed 9 months ago by tboeckel

empty text object instead of HSpace

comment:12 in reply to: ↑ 11 Changed 9 months ago by tboeckel

Replying to javierdlr:

Testing with MUI3.9 and no problems so far. Let me test it a few more days and will post here results. TIA.

Sounds interesting, but this still doesn't ring a bell for me.

Anyway, I created two more versions of YAM to test. The "hspace" version does some other coloring of the single pages of a page group, but is identical to the normal nightly builds in all respects. The "text" version uses a different object for the empty page, but with the same coloring as the "hspace" version. Perhaps this makes a difference.

The colors for reference:
red (0xff0000) empty page
green (0x00ff00) progress page, mostly covered by the gauge
blue (0x0000ff) simple information text

comment:13 Changed 9 months ago by tboeckel

Any news on this issue regarding MUI 3.9 or the updated color versions and MUI 4.0?

comment:14 Changed 9 months ago by anonymous

Ok after a few days I couldn't reproduce the "rectangle_efect" using either YAM .hspace or .text versions. Now/today (9-11-2013) I reverted to daily debug version and seems ok. In a couple of days I'll post here more results. THX

comment:15 Changed 8 months ago by javierdlr

Today I got the rectangle (in grey) while using the special YAM.hspace compilation. Changed to use YAM.text compilation will tell you more in a couple of days. THX for being/having patience.
Using latest MUI4 version

Changed 8 months ago by javierdlr

YAM.hspace showing rectangle (in grey)

comment:16 Changed 8 months ago by tboeckel

Any news for the "text" version?

comment:17 Changed 8 months ago by javierdlr

Ok with YAM.text I got the same rectangle, but it takes a lot more to appear (like with YAM.hspace) than normal debug version.
Will try those two version on plain update6 and again with MUI39 and post results ASAP.

Changed 8 months ago by javierdlr

YAM.text version

comment:18 Changed 7 months ago by javierdlr

With final YAM2.9 (now using YAM2.10dev) I don't get such "grey" rectangle anymore!!!! :-)
Will post it after xmas if still ok.

THX

comment:19 Changed 7 months ago by damato

  • Resolution set to invalid
  • Status changed from new to closed

Ok, we will then close this ticket. Please reopen if the issue comes back.

comment:20 Changed 6 months ago by javierdlr

Since a couple of days the 'grey rectangle' showed again :-/
Will do some tests and post here results.
Using 2.10dev nightly builds
Maybe is some sort of latest MUI4 (I'm betatestter) and YAM? Will try with public OS4.1 upd6 and see what happens.

comment:21 follow-up: Changed 5 months ago by javierdlr

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi, if in YAM I have (MSG_CO_TransferWin) "Transfer window" NOT set to "hide always" I don't get the grey rectangle problem.
So maybe is some string that shows in YAM main window when "Transfer window" is "hide always", that doesn't show if transfer window shows up.

Version 0, edited 5 months ago by javierdlr (next)

comment:22 in reply to: ↑ 21 Changed 5 months ago by tboeckel

  • OS Platform set to undefined

Replying to javierdlr:

Hi, since updated to 2.10dev the 'grey rectangle' showed again :-/

If in YAM I have (MSG_CO_TransferWin) "Transfer window" NOT set to "hide always" I don't get the grey rectangle problem.
So maybe is some string that shows in YAM main window when "Transfer window" is "hide always", that doesn't show if transfer window shows up.

There are some things you can try for us:

  1. don't use any language catalog. Start YAM using the NOCATALOG option (ToolTypes or commandline).
  2. set the status bar to a different location, i.e. bottom or invisible.
  3. let MUI use the default settings. I don't really think that your "classic OS3" look could be the culprit, but who knows...

comment:23 Changed 5 months ago by javierdlr

Ok using NOCATALOG option and MUI default settings. Will post news here ASAP.

comment:24 Changed 5 months ago by damato

  • Status changed from reopened to pending

Any news on that issue?

comment:25 Changed 5 months ago by javierdlr

Since using internal strings (NOCATALOG) and default MUI settigns no problems, so far.
So, seems "my fault" in some MUI settings, just trying to find what in MUI is causing the "grey ractangle".
I suspect is in MUI BUTTONS settings, will go one by one settings in MUI BUTTONS and post here (or MUIdev web) results.

THX for being patience with such "problem".

comment:26 Changed 4 months ago by javierdlr

With NOCATALOG and MUI defaults prefs (changed only Buttons GAUGE settings) I got today the rectangle problem in YAM, so maybe is MUI problem (too small gauge height to fit image/text/button?).

Attached is MUI prefs with such change, hope you can reproduce it.

THX and sorry for the hassle.

Changed 4 months ago by javierdlr

MUI default prefs. Only changed GAUGE settings

comment:27 Changed 4 months ago by tboeckel

  • Component changed from user interface to foreign component
  • Milestone set to YAM 2.9p1
  • OS Platform changed from undefined to AmigaOS4
  • Priority changed from undecided to normal
  • Resolution set to fixed
  • Status changed from new to closed

According to a private mail from Javier this issue will be fixed by the upcoming release of MUI 4.0-2014R3.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Javier de las Rivas(Reporter, Participant)