close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

#448 closed bug (invalid)

Crash when creating new folder (too hastily)

Reported by: JosDuchIt Owned by:
Priority: undecided Milestone: YAM 2.9
Component: undefined Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

When you create a new folder you are confronted with 2 textin gadgets to enter the display name and the Folder name
When the "dispay name" field is entered, this input is duplicated in the second field "Folder Name"
Previously say with 2.8 you had to enter the name yourself, or use the possibility to select the folder with a requester. First time users of 2.9 will often not see the folder name is (slightly) ghosted and go on clicking on the OK button.
A crash will occur

Steps to reproduce

  1. Open the "dossier/nouveaudossier menu
  2. Select your type of folder eg "interne" (default)
  1. enter your display name in foirst textin gadget

4 Hit theOK button

Expected results

Actual results

Regression

Notes

Attachments (2)

crashlogFolder (4.7 KB) - added by JosDuchIt 14 months ago.
Crashlog_YAM.debg_2013-11-07_11-15-14.txt (34.8 KB) - added by anonymous 14 months ago.

Download all attachments as: .zip

Change History (7)

Changed 14 months ago by JosDuchIt

comment:1 Changed 14 months ago by tboeckel

Sorry, but you attached a Snoopy log, not a real crash log created by the GrimReaper. The Snoopy log is useless. It cannot contain any crash related information.

comment:2 Changed 14 months ago by tboeckel

What "ghosted" string object are you refering to? There is nothing ghosted or disabled in the folder edit window, except the mailing list objects at the bottom until you enable the mailing list support.

The "Folder name" string has slightly different colors, because it is not the active object, just like the "max age" string object or any other string object. For the "Welcome" and "Closing" phrase string objects the difference might not be noticed that easily as they are empty by default.

Changed 14 months ago by anonymous

comment:3 Changed 13 months ago by tboeckel

Have you been able to reproduce this issue? For me adding and removing folders works perfectly, even if the config or the search window is open. I mention the additional windows, because these are using object which get update whenever the folder tree is changed. And your crash log is pointing to the folder tree refresh method at some point.

comment:4 Changed 13 months ago by JosDuchIt

I have been able to do that a number of times.
I now retested with NB 13/11 and 17/11 and they work very well, you can even after having typed in a new name with no return, go straight to the OK button: no crash & folder is created.
Ticket can be closed for me

comment:5 Changed 13 months ago by damato

  • Milestone set to YAM 2.9
  • Resolution set to invalid
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Joseph Duchâtelet(Reporter, Participant)