close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 13 months ago

Closed 12 months ago

Last modified 11 months ago

#451 closed bug (fixed)

YAM NB 17/11/2013 overrwrites filter settings

Reported by: JosDuchIt Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9
Component: configuration Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed a potential problem where YAM was overwriting filter settings.

Description

Summary

When copying the archive over the existing install, all action contentof the filters is set to
FI02.RedirectTo =
FI02.ForwardTo =
FI02.ReplyFile =
FI02.ExecuteCmd =
FI02.PlaySound =
FI02.MoveToFolderID = 00000000

Steps to reproduce

1.
2.

Expected results

Actual results

Regression

Notes

Attachments (3)

Crashlog_YAMdebug_2013-11-19_09-30-48.txt (32.1 KB) - added by JosDuchIt 12 months ago.
Crashlog_YAMdebug_2013-11-20_11-05-55.txt (34.7 KB) - added by JosDuchIt 12 months ago.
Debugdump-17-11 (312.2 KB) - added by JosDuchIt 12 months ago.
after freeze when using folders dragbar

Download all attachments as: .zip

Change History (21)

comment:1 Changed 13 months ago by JosDuchIt

I copied from a correct .configOK to .config
Launched YAM
Hit the "filter" button
the same error message appears telling me some masg in the incoming file could not be moved to a non identifie'd drawer
verified the content of .config
It had overwritten the filter actions again.

comment:2 Changed 13 months ago by tboeckel

  • Component changed from undefined to configuration
  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Status changed from new to assigned

Please restore the old and working .config file again and capture a CONFIG FILTER FOLDER log using the debug version. This should reveal why the folders are not resolved correctly.

Please keep the old and working .config file until this issue is solved.

comment:3 follow-up: Changed 13 months ago by JosDuchIt

I always use 2.9Dev in debug version
Can you explaine "capture a CONFIG FILTERR FOLDERR" ?

comment:4 in reply to: ↑ 3 Changed 13 months ago by tboeckel

Replying to JosDuchIt:

I always use 2.9Dev in debug version
Can you explaine "capture a CONFIG FILTERR FOLDERR" ?

Type this in a shell before running YAM:
setenv yamdebug config filter folder file:t:yamlog

This will produce the log file in "t:yamlog"

Please attach that log here afterwards.

Details about YAM's debugging facilities can be found in the FAQ.

comment:5 Changed 13 months ago by JosDuchIt

Forgot to use the correct .config file before making the test asked for.
It will have to wait till tomorrow, just got visitors.

comment:6 Changed 13 months ago by JosDuchIt

copied the correct .config file
no get messages,

no new messages that needed to be moved (at least i did not note filterint)
hit the filter button
17 messages moved
Yamlog2 uploaded

comment:7 Changed 13 months ago by tboeckel

There are some oddities with you configuration.

  1. Your folders have localized names (i.e. Reçus, Envoyés) but your user identities refer to the english names (i.e. Incoming, Sent). This difference is most likely caused by the nightly build 2013-11-15, because I changed YAM to use the translated names instead of the english ones later on that day. Please check your POP3 and SMTP server as well as your user identities to reference existing Incoming and Sent folders.
  1. Two of your filters, namely "Jée" and "Duch" reference non-existing folders. For example the filter "Duch" should move mails to the folder "JDuch", but that one doesn't exist as can easily be seen from the list of folders been loaded right before the check. However, a folder named "Duch" does exist.
  1. For the filter "Jée" things are even worse. There exists a folder named "Jée" which seems to be the UTF8 encoding of "Jée". I cannot tell how you managed to type that name, but since UTF8 is not yet supported by any version of AmigaOS such a name is not going to work. Additionally, although both names are essentially equal they are different due to the different encoding and the different length (3 characters vs. 4 characters).
  1. There are still some filters with empty match strings for some rules. Although such rules don't cause any harm they are absolutely redundant and will never cause a filter to match and to perform its actions. The filters with such no-op rules are named "SPAM", "Guy" and "familie". Please check these.

All in all you should check your configuration on the pages "TCP/IP", "Identities" and "Filters" for valid folders. I am quite sure you will see some "empty" folders in certain places. I am very sure everything will be working again afterwards. I'd say you are facing the negative side effects of YAM's nightly builds. Things may misbehave from time to time. This is the price you have to pay for using the most recent development versions.

I did lots of upgrade procedures from older configurations to the current state and I am very sure that everything is upgraded correctly now. Thus, if everything is working again after checking your configuration, please let us know. We will close this ticket then.

comment:8 Changed 13 months ago by tboeckel

Deleted the two logs on Joseph's request. Please note that I kept them on my machine for possible later reference.

comment:9 follow-up: Changed 12 months ago by JosDuchIt

edited my backup .config file .configOK only for the password of one of my mailservers.&
-named it .configTest

  • made an other copy edited for other problems (JDuch Jée filters, named it .configOK.

it contains
FI18.Name = Jée
FI18.Remote = N
FI18.ApplyToNew = Y
FI18.ApplyToSent = Y
FI18.ApplyOnReq = Y
FI18.Combine = 1
FI18.Field0 = 0
FI18.SubField0 = 1
FI18.CustomField0 =
FI18.Comparison0 = 0
FI18.Match0 = Alumni
FI18.CaseSens0 = N
FI18.Substring0 = Y
FI18.DOSPattern0 = Y
FI18.SkipEncrypted0 = N
FI18.Actions = 32
FI18.RedirectTo =
FI18.ForwardTo =
FI18.ReplyFile =
FI18.ExecuteCmd =
FI18.PlaySound =
FI18.MoveTo = Jée

Installed last NB 19/11
copied .configOK to .config
Verified the Jée folder exists: OK
The other Jée -bizarresigns exist too: i did never create it that way :

it was always named Jée eg in my SAM440ep installs
The name must have been changed by some application, maybe when copying


Launched yam
Get mesages, no new messages

Filter button could not be used on "incoming"

Opened Settings window

JDuch filter was set correctly

Tried to view Jée filter
Opened the action tab
the Move textin gadget pointed to quite another "tree item" (it is the last you looked at, and don't know how YAM is picking up the tree-item if it is the first you look at, looking at does not generate a crash) but:
Opened the "look for correct tree-item " right of the textin gadget
crash - see attached crashlog

Changed 12 months ago by JosDuchIt

comment:10 Changed 12 months ago by tboeckel

(In [7332]) * mui/FolderRequestPopup.c: added a NULL pointer check for unresolved folders. This refs #451.

comment:11 in reply to: ↑ 9 Changed 12 months ago by tboeckel

Replying to JosDuchIt:

Launched yam
Get mesages, no new messages

Filter button could not be used on "incoming"

Why not? You are omitting the basic details here.

Tried to view Jée filter
Opened the action tab
the Move textin gadget pointed to quite another "tree item" (it is the last you looked at, and don't know how YAM is picking up the tree-item if it is the first you look at, looking at does not generate a crash) but:
Opened the "look for correct tree-item " right of the textin gadget
crash - see attached crashlog

That crash should be fixed with the next nightly build.

comment:12 Changed 12 months ago by JosDuchIt

Why not? You are omitting the basic details here.

I did note the button was ghosted, when i wanted to use it , so it did not work. I conjectured that this might be a correct reaction if YAM remembers it filtered just before or if it noted no new messages were received in the incoming folder. Then again i doubted this was the case.
I really cannot give more details. It was unexpected, no crash or freeze debug or snoopy output available.

Changed 12 months ago by JosDuchIt

comment:13 Changed 12 months ago by JosDuchIt

That crash should be fixed with the next nightly build.

Interface remark: Did comment on this after a crash did see, that i was not looged in
Did log in, and lost the comment :(

Here it is again:

used the settings window
went to filters
chose the Jée filter
chose the action tab
the move textin gadget was empty
using the treebrowser i could not see the Jée folder

Went to the folder/new menu
Entered Jée as foldername
Got a message "folder exists, do you want to continue ? If yes, folder will be erased/changed
chose continue
Got crash
crashlog joined

comment:14 Changed 12 months ago by tboeckel

I think I found the reason for the crash. YAM used a wrong object as destination object for a notification which then caused an access to a no longer existing object as soon as the notification was triggered. Please try again with the next nightly build and reopen this ticket if it is still not fixed.

comment:15 Changed 12 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7350]) * mui/FolderRequestListtree.c: set the notification for a changed folder tree for the correct object. The former approach used the NListview object instead of the NListtree object. This might have caused a crash, because the notification was never removed and a changed folder tree would then access a no longer existing object when the notification was eventually triggered. This closes #451.

comment:16 Changed 12 months ago by JosDuchIt

Downladed the archive & installe it.
As soon as yo try to use the mouse wth the slider gadget to view other folders you get eiter very slow reatons or a freeze.

Dumpdebugbuffer will be joined

Changed 12 months ago by JosDuchIt

after freeze when using folders dragbar

comment:17 Changed 12 months ago by damato

I am sorry, but the debug/crash log you provided is

  1. way too long with having catched way too much information not related to YAM and
  2. doesn't show any crash related to YAM.

So I see nothing new or related to YAM here which would tell us that the problem isn't fixed.

comment:18 Changed 11 months ago by damato

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed The owner will remain tboeckel.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Joseph Duchâtelet(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)