close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 8 months ago

Closed 8 months ago

Last modified 7 months ago

#453 closed bug (fixed)

Difficulties with addresssbook

Reported by: JosDuchIt Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9
Component: MIME handling Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed a problem with entering new addresses in the address book because of an incorrect memory copy routine use.

Description

Summary

Entering an address form addressbookis more difficult than some NB ago

  1. entering an alias in the To field and sending the msg gives an error "unknown alias
  2. going to the addressbook, from the messages To field button, selcting the alisa, hitting to, going to the To filed in the message and entering, then sending the msg: same error
  3. typing the beginning of a real address or alias, selecting one that appears, then enter, then send, very often will not be sent

see below

Steps to reproduce

1.type slowly the beginning of some YAM known address (eg your own)

  1. when the righ line appears highlighted : enter
  2. send

Expected results

msg sent

Actual results

error
Bad response from mail server
'smtp.scarlet.be' to command 'RCPT':

550 5.1.1 <Joseph>... User unknown

The message is saved in outgoing (en attente) with as address "Joseph"

Regression

I understand this is trying with previous NB's ?

Notes

Attachments (0)

Change History (3)

comment:1 Changed 8 months ago by tboeckel

  • Component changed from undefined to MIME handling
  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Status changed from new to assigned
  • Version changed from 2.8 to nightly build

comment:2 Changed 8 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7330]) * mime/rfc2047.c: restored a formerly replaced memcpy() call as the strlcpy() function omits certain characters due to the length restriction. This closes #453.

comment:3 Changed 7 months ago by damato

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Joseph Duchâtelet(Reporter)
  • Thore Böckelmann(Owner, Participant)