close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 3 years ago

#46 closed enhancement (fixed)

Account based preselection window

Reported by: anonymous Owned by: somebody
Priority: undecided Milestone: YAM 2.7
Component: mail filtering Version:
Severity: minor Keywords:
Cc: mario@… OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by tboeckel)

as i am using the prewiev for deleting spam on the server, it would be nice if this option could be switched on or off for every mail-account seperately. this is because i have only 2 accounts that receive spam, the others are "clean". otherwise, great work, yam is getting better and better ;)


Moved from SF:
https://sourceforge.net/tracker/?func=detail&aid=691549&group_id=13560&atid=363560

Attachments (0)

Change History (14)

comment:1 Changed 4 years ago by damato

  • Priority changed from major to undecided
  • Severity set to major

comment:2 Changed 4 years ago by damato

  • Component changed from stable build to undefined

comment:3 Changed 4 years ago by damato

  • Cc yamos-svn@… removed

comment:4 in reply to: ↑ description Changed 4 years ago by padrino

I'd suggest something like this:

in TCP/IP POP3 prefs add "trigger preselection"
in new mail prefs add to preselection "dpeend on TCP/IP setting"

Of course the naming could be different and also the implementation ;)

This is just an idea how it could work.

comment:5 Changed 4 years ago by padrino

  • Cc mario@… added

comment:6 Changed 3 years ago by tboeckel

  • Description modified (diff)
  • Status changed from new to accepted

comment:7 Changed 3 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [5556]) * misc: It is now possible to define the mail preselection individually for

each account. This closes #46. The same applies for the "avoid duplicates"
setting.

comment:8 Changed 3 years ago by tboeckel

  • Milestone set to YAM 2.7

comment:9 Changed 3 years ago by padrino

  • Resolution fixed deleted
  • Status changed from closed to reopened

Thanks for this one!

Unfortunatelly it does not work. :-/
Prefs are always set back to "never".
Try change them in tcp/ip, press safe/use. Return to prefs and see, all is re-set.

comment:10 Changed 3 years ago by tboeckel

Hm, this one works for me as expected, no matter how often I try to reproduce this issue. However, what was not working as expected is the "Apply remote filters" setting. Just committed the necessary change for that one. Did you mix up these two?

comment:11 Changed 3 years ago by tboeckel

  • Status changed from reopened to pending

comment:12 follow-up: Changed 3 years ago by tboeckel

  • Component changed from undefined to mail filtering
  • Severity changed from major to minor

padrino, any news from your side?

comment:13 in reply to: ↑ 12 Changed 3 years ago by padrino

Sorry,

I replied, but forgot to login, so maybe my comment is still waiting for moderation...
The problem is still here, with yesterdays verion, with "filter-fix". Sorry, have no access to aOS right now.
The problem is, when I go to prefs and set to "always" it is reset to "never" when I return, *but* when I check and uncheck the filter setting before that and then switch to "always", the setting will stay and will not be reset...

comment:14 Changed 3 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from pending to closed

(In [5568]) * MailServers.c: added missing comparison of the preselection mode. This closes #46.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Mario Cattaneo(Subscriber, Participant)