close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 11 months ago

Closed 11 months ago

Last modified 10 months ago

#461 closed bug (fixed)

Crash while typing in write window

Reported by: hypex Owned by:
Priority: undecided Milestone: YAM 2.9
Component: user interface Version: 2.8p1
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed a crash bug when in the write window the autosave functionality activates while typing.

Description

Summary

I was typing a reply in the write window when I looked up and a crash had occurred. The Grim Reaper had opened and I had pressed return after it did. I saved the crash log. I had to reboot. The UpdateTreeStatistics() function was involved.

Steps to reproduce

  1. Select to reply to an email.
  2. Type in a sucha way as to reproduce bug.
  3. I think I randomly found it. :-)

Attachments (1)

Crashlog_YAM_2013-11-25_00-27-14.txt (31.2 KB) - added by hypex 11 months ago.

Download all attachments as: .zip

Change History (5)

Changed 11 months ago by hypex

comment:1 Changed 11 months ago by tboeckel

  • Milestone set to YAM 2.9
  • Resolution set to fixed
  • Status changed from new to closed

The crash happened while YAM was automatically saving the current mail as draft. Since the draft mail handling has been completely reworked in YAM 2.9-dev it is very likely that this kind of crash has been fixed already.

Perhaps you might want to try yourself and use YAM 2.9-dev. Please remember to make a backup of all your settings files and mails, because YAM 2.9-dev will make several irreversible changes to certain files and folders. You have been warned...

If this issue should be still occur with YAM 2.9-dev then please reopen this ticket. I will close it as "fixed" for the time being.

comment:2 Changed 11 months ago by hypex

Thanks for the quick response and fix. :-)

By the sounds of it 2.9 contains some drastic chnages like 2.7 did. If only I didn't have 1000's of emails this wouldn't bother me so much. Even on SFS backing up little lots of large data is a nightmare.

I do wonder if an interim update for the current 2.8 would be good that includes major bug fixes that crash. IOW a final stable release before the version bump.

comment:3 Changed 11 months ago by tboeckel

I affraid an interim release is not going to happen.

The changed draft handling is not just a single changeset which could be merged into the YAM 2.8p1 source code. It is merely a longer process which involved lots of changes until the current state. I cannot tell which change exactly might fix this crash. We are simply lacking time and man power for such an interim step. The scheduled release date is around Christmas this year (2013 that is ;)). We will only be fixing bugs until then.

You can install YAM 2.9-dev into a separate directory with a separate mail directory. Just copy over either a selection or all of your mails to this 2.9-dev mail directory for testing purposes. Your 2.8p1 mails will then be unaffected by any bugs in 2.9-dev and going back to 2.8p1 is as simple as it can be.

comment:4 Changed 10 months ago by damato

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Damien Stewart(Reporter, Participant)