close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 8 months ago

Closed 6 months ago

#468 closed bug

YAM crash while (auto) saving Indexes

Reported by: opiopi Owned by:
Priority: undecided Milestone:
Component: mail indexing Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

YAM crash while (auto) saving Indexes. It also crashes sometimes when i filter E-Mails.
I have no more information but maybe the MuOutput.txt help to find the bug.
If not i can investigate the problem next weekend...

Used version: YAM 2.9-dev (30.11.2013)
Copyright (C) 2000-2013 YAM Open Source Team [OS3/m68k, r7366]

Attachments (5)

MuOutput.txt (4.7 KB) - added by opiopi 8 months ago.
YAM-Hit.txt (6.4 KB) - added by opiopi 8 months ago.
Errormessage.txt (160 bytes) - added by opiopi 8 months ago.
YAM-log-cut-11.12.2013.txt (52.8 KB) - added by opiopi 8 months ago.
YAM-Hit-11.12.2013.txt (16.0 KB) - added by opiopi 8 months ago.

Download all attachments as: .zip

Change History (15)

Changed 8 months ago by opiopi

comment:1 Changed 8 months ago by tboeckel

Unfortunately the log doesn't help. At least I am not able to extract more information from it than that the crash happens while freeing a mail, which can happen at any time.

If possible then please try to make this crash reproducable and give exact instructions how to archive that.

comment:2 Changed 8 months ago by opiopi

I do a lot of tests and i think i found a case in which the crash always occur:

  1. run YAM and go to the outgoing folder
  2. click new and write a new mail, add e.g. you own adress,a subject and some text in the body
  3. wait until the mail gets autosaved
  4. go to attachments tab and add a attachment
  5. click send now

here i get a errormessage and a hit from mutools. both attached to this ticket.

Changed 8 months ago by opiopi

Changed 8 months ago by opiopi

comment:3 Changed 8 months ago by tboeckel

I followed your steps exactly with all kinds of debugging tools running but for me everything is done alright and without any crash. Even enabling/disabling the embedded read pane makes no difference.

Could you please generate a MAIL,FOLDER,UTIL log using the debug version? Perhaps this reveals what is going wrong for you.

comment:4 Changed 8 months ago by opiopi

I was using the non debug version and IIRC the crash doesn't happen with the debug version. Can you please test the above steps with the non debug version? I can do some more tests tomorrow.
BTW: Sometimes YAM crash here also if i use YAM in a normal way (getting mails, reading mails, filter mails) and quit YAM. Then YAM show the Quit splash window and crashes. After the crash the splash and the main window is still open and i must reset the system.

comment:5 Changed 8 months ago by tboeckel

I did use the non-debug build, although my own build done with the same compiler. But that should not make any difference. But nevertheless, it would be interesting if the debug build is really not affected. So please try to reproduce the crash using the debug build. I will check again with the official non-debug nightly build, too.

Regarding the crash when quitting YAM: no crashlog, no help. Sorry. The plain information "it crashes" is not enough.

comment:6 Changed 8 months ago by opiopi

The step 1. (see above) should be "run YAM and go to the drafts folder" but only to see in the mainwindow (in background behind the write window) if the autosave is done.

This time i follow the steps 1-5 and quit YAM after step 5.
I write the log to a file and i got the crash now with the debug version too.
The logfile was more as 77 MB in length because YAM was scanning the send folder from the last crash. I cut a lot of lines (see in the file)
I add the logfile and the crashlog as "YAM-log-cut-11.12.2013.txt" and "YAM-Hit-11.12.2013.txt".

BTW: the log contain a line "timer event received but no timer was processed" but no hint which timer event was received.

Changed 8 months ago by opiopi

Changed 8 months ago by opiopi

comment:7 Changed 8 months ago by damato

  • Component changed from coding/memory to mail indexing

Same here: Please try to reproduce the problem with the latest nightly build first! No reports on old nightly builds please.

comment:8 Changed 8 months ago by opiopi

Same here: 1. Yes it is *always* reproducible! Did you try it???

  1. here was not much changes in the nightly builds and it should be possible to reproduce the bug for you too.

If you really want logfiles from the latest nightly build you must wait at least until friday because such debug sesson with the debug version need really much time.

comment:9 Changed 7 months ago by damato

  • Status changed from new to pending

Does this problem still exist with the official 2.9 version? Please try to reproduce and report back.

comment:10 Changed 6 months ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter, Participant)