close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 13 months ago

Closed 13 months ago

Last modified 12 months ago

#469 closed bug (fixed)

YAM doesn't close the write window in a message without a "to" entry

Reported by: opiopi Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9
Component: user interface Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

restored the previous behavior of allowing a write window to be closed with no recipient being entered.

Description

YAM doesn't close the write window in a message without a "to" entry.
Steps to reproduce:

  1. Write a new message
  2. add NO adress into the "To" textfield
  3. click "send later"
  4. click in the requester "add later"
  5. the message is saved but the window is still open.

In older versions of YAM the window is closed in such case, which makes sense for me.

Used version: YAM 2.9-dev (30.11.2013)
Copyright (C) 2000-2013 YAM Open Source Team [OS3/m68k, r7366]

Attachments (0)

Change History (3)

comment:1 Changed 13 months ago by tboeckel

  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Status changed from new to assigned

I'd say this is due to the changed handling of draft mails since YAM 2.8p1. Mails without a receiver are saved as draft mail now if the user chooses "Add later". But you are right. As the "Send later" button usually closes the window it should do so in this situation as well. However, the mail is incomplete and cannot be sent as it is. Thus I suggest to rename the "Add later" button to "Save as draft" and to let YAM close the window nevertheless.

comment:2 Changed 13 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7368]) * mui/WriteWindow.c: renamed the first answer of the confirmation requester if the user chooses to send a mail without a receiver from "Add later" to "Save to draft and close window" as this is what is really done. The write window will be closed, because this is the intended action of the "Send now/later" buttons. This closes #469.

comment:3 Changed 12 months ago by damato

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed The owner will remain tboeckel.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter)
  • Thore Böckelmann(Owner, Participant)