close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 months ago

Closed 3 months ago

#479 closed bug (invalid)

All mails was sent from Drafts folder

Reported by: Tsk000 Owned by:
Priority: normal Milestone: YAM 2.9p1
Component: user interface Version: 2.8p1
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

All mails was sent from the Drafts folder which should never happen in any case.

Steps to reproduce

  1. Select Outgoing folder
  2. Select any mail in the Outgoing folder
  3. Press the Send button in main GUI
  4. It will send all mails from both the Outgoing and Drafts folders instead of sending the selected one only

Expected results

Any email client should never send out anything from the Drafts folder in any case

Actual results

The opposite what was expected

Regression

Notes

Attachments (0)

Change History (5)

comment:1 Changed 4 months ago by damato

  • Reporter changed from TSK to Tsk000

Does this problem still exist when you try to reproduce it with one of the latest nightly builds? (see http://nightly.yam.ch/)

comment:2 Changed 4 months ago by Tsk000

I wasn't able to reproduce this problem with 2.8p1 or with 2.9dev today anymore. What I did when it happened: 1. Create two mails leaving their windows open, 2. Send both emails one at a time, YAM sends the first one but not the second one which is left in Outgoing folder (this is reproducible every time). 3. Then I was trying to find menu item to send one selected mail only. I tried context menus first and then normal menus. After that I pressed the Send button. I guess this problem might happen only in rare cases. Or toying with menus first somehow affected it.

There's discussion in AmigaWorld.net where somebody else said having the same problem so I'm not the only one: http://amigaworld.net/modules/newbb/viewtopic.php?topic_id=38536&forum=32

comment:3 Changed 4 months ago by damato

  • Component changed from undefined to user interface
  • Milestone set to YAM 2.9p1
  • Priority changed from undecided to normal

I admit that others seem to have reported that too on amigaworld.net. However, I wasn't able to reproduce that in any case here. So this issue seems to require some more attention and testing from your side as well as from our side so that we can identify a procedure that clearly reproduces the problem. Thus, I will file that ticket to be more closely investigated within the 2.9p1 milestone.

So please try to generate a reproducible case and please also use the official 2.9 version to try to reproduce the issue.

comment:4 Changed 3 months ago by tboeckel

  • Status changed from new to pending

Any news on this issue? I admit the Draft handling of YAM 2.8p1 might have had some bugs, but these should be fixed now with YAM 2.9.

comment:5 Changed 3 months ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Tuomas Hokka(Reporter, Participant)