close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 11 months ago

Closed 11 months ago

Last modified 8 months ago

#484 closed bug (fixed)

When receiving emails a MUI error/warning window pops up saying "MUI_Redraw() was called from task..."

Reported by: damato Owned by: tboeckel
Priority: high Milestone: YAM 2.9p1
Component: user interface Version: 2.9
Severity: major Keywords:
Cc: ncc@… OS Platform: All
Blocked By: Blocking:
Release Notes:

fixed a thread safety issue which resulted in GUI operations being executed not from the main YAM thread but from a different thread. This caused MUI to popup a warning under certain circumstances when downloading mails.

Description

Summary

When using YAM 2.9 with MUI4 on AmigaOS4 and receiving emails, potentially the following error might come up:

MUI_Redraw() was called from task ... instead of the application's main task!

This is a violation of basic MUI rules!

Steps to reproduce

  1. configure a multiple number of accounts in YAM and try to receive mails from these accounts several time.
  2. retry to do the same with enabled preselection to better trigger the problem.

Expected results

The mails should be received without such an error/warning

Actual results

The mails are received, but the requester pops up and suspends transfer for a second or two.

Notes

The error seems to be depending on runtime conditions. Thus, it does not always and every time pop up. So depending how busy YAM is or how many emails are received the requester pops up or not. That might be the actual reason why it slipped into the 2.9 release.

It is not clear yet whether "preselection" is required to trigger this warning or if it also occurs if no preselection is enabled at all.

Attachments (0)

Change History (3)

comment:1 Changed 11 months ago by tboeckel

  • Owner set to tboeckel
  • Status changed from new to assigned

comment:2 Changed 11 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7436]) * YAM_UT.c: changed the DisplayStatistics() function to be thread safe. It could happen that a POP3 mail transfer was initiated while the Incoming folder was not the currently active folder and hence its index was flushed from memory before. The POP3 download would then trigger an index reload for the Incoming folder which in turn would update the global folder statistics. That would eventually happen from a different thread than the main thread and produce a warning requester with recent MUI version. The thread safety now closes #484.

comment:3 Changed 8 months ago by damato

  • OS Platform set to All
  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Jens Maus(Reporter, Participant)
  • ncc@…(Subscriber)
  • Thore Böckelmann(Owner, Participant)