close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 9 months ago

Closed 9 months ago

Last modified 5 months ago

#489 closed bug (fixed)

Signature will get two leading and two ending unterlines at email addresses und URLs

Reported by: AmigaSurfer Owned by: damato
Priority: normal Milestone: YAM 2.9p1
Component: configuration Version: 2.9
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

fixed the signature text editor to not parse the signature text via the ParseEmailText() function as otherwise the text styles end up in mixing up a specified signature.

Description

Summary

Steps to reproduce

  1. Press "Konfig"
  2. Select "Signatur"
  3. The email address and URL in the old signature shown blue
  4. Select the second signature
  5. Select the first signature again

Expected results

Unchanged blue email address and URL

Actual results

Underlined email address and URL with an underlined underline before and after the email address and URL.
Removing this underlined underlines within YAM doesn't works.

Regression

Notes

While trying to remove all underline signs with "Im externen Editor bearbeiten" leads to blue email address and URL after saving the signature with ED. But after changing all three signatures this way back, saving config and trying to write new mail I got an crash.
After reboot I removed the underlined underlines within YAM in the first signature and got a crash while selecting the second signature. But now I can't reproduce this crash.

Attachments (0)

Change History (3)

comment:1 Changed 9 months ago by damato

  • Milestone set to YAM 2.9p1
  • Owner set to damato
  • Priority changed from undecided to normal
  • Severity changed from major to minor
  • Status changed from new to assigned

comment:2 Changed 9 months ago by damato

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7428]) * mui/SignatureTextEdit.c: modified the signature text editor to not

parse the signature text via the ParseEmailText() function as otherwise
the text styles end up in mixing up the signature. This closes #489.

comment:3 Changed 5 months ago by damato

  • OS Platform set to All
  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Busse(Reporter)
  • Jens Maus(Owner, Participant)