close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 10 months ago

Closed 9 months ago

Last modified 9 months ago

#491 closed bug (fixed)

Files "in use" block part of YAM 2.9 install script

Reported by: amigaak2@… Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9p1
Component: installation Version: 2.9
Severity: minor Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

reworked the Installer script to check for a running instance of YAM. If that is the case then the user is prompted to terminate that instance to make sure that no files which might get overwritten during the installation are locked. After the installation a reboot is recommended to ensure that updated libraries and classes are really flushed from memory.

Description (last modified by damato)

Summary

config, and one or two other files remained "in use" after I had been running YAM 2.8 before installing 2.9, which blocked installation until rectified. Also starting 2.9 failed at first because codesets.library 6.15 was in memory although 6.16 had been installed.

Steps to reproduce

1.
2.

Expected results

Actual results

Regression

Notes

Attachments (0)

Change History (5)

comment:1 Changed 10 months ago by damato

  • Description modified (diff)
  • Milestone set to YAM 2.9p1
  • Severity changed from major to minor

Please note, that the installation script should check if currently a YAM version is running and perhaps request to close it. In addition, at the end it should ask the user to reboot since a common fault seems to be that users tend to start YAM right away but old, outdated third-party classes/libraries are still in use.

comment:2 Changed 10 months ago by damato

  • Status changed from new to accepted

comment:3 Changed 9 months ago by tboeckel

  • Owner set to tboeckel
  • Status changed from accepted to assigned

comment:4 Changed 9 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7609]) * doc/Install-YAM: reworked the Installer script to check for a running instance of YAM. If that is the case then the user is prompted to terminate that instance to make sure that no files which might get overwritten during the installation are locked. After the installation a reboot is recommended to ensure that updated libraries and classes are really flushed from memory. This closes #491.

comment:5 Changed 9 months ago by tboeckel

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Thore Böckelmann(Owner, Participant)