close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 8 months ago

Closed 7 months ago

Last modified 5 months ago

#493 closed bug (fixed)

Crahs in DateStamp2String()

Reported by: Elwood Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9p1
Component: user interface Version: 2.9
Severity: major Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

fixed a rare crash bug where YAM crashed in DateStamp2String() due to a missing NULL pointer check.

Description

Summary

DSI in
DateStamp2String()+0x50 (section 2 @ 0x32B2C)

Steps to reproduce

I don't know.
What I was doing is: deleting emails, one after another. At some point, maybe on a particular email, YAM crashed.

Expected results

Actual results

Regression

Notes

Full crashlog attached

Attachments (3)

Crashlog_YAM_2013-12-29_11-47-25.txt (32.8 KB) - added by pferrucci@… 8 months ago.
Crashlog_YAM.debug_2014-01-05_12-17-20.txt (32.2 KB) - added by pferrucci@… 8 months ago.
Log done with 2.9 debug
Crashlog_YAM.debug_2014-01-27_21-55-02.txt (33.2 KB) - added by Elwood 7 months ago.
Crashloh with YAM.debug 2014-01-18

Download all attachments as: .zip

Change History (19)

Changed 8 months ago by pferrucci@…

comment:1 Changed 8 months ago by damato

  • Status changed from new to pending

Sorry, we are not able to reproduce the problem nor identify the reasons based on your crash log. Can you please try to reproduce the problem/crash with the debug version and report back and send us another crash log performed with the debug version.

Changed 8 months ago by pferrucci@…

Log done with 2.9 debug

comment:2 Changed 8 months ago by Elwood

I found something new:

  • it doesn't happen if I delete emails very fast i.e. without letting YAM display the email content in the preview area
  • if I delete emails pressing the Del key every half second, YAM displays the email text and after a few emails only, it says in the status area, at the top right of Yam: "deleting 1 message(s)" with a progress bar filled at 100% and saying "1/1".

Then it halts for one second and then GrimReapper appears.

comment:3 Changed 8 months ago by damato

  • Component changed from undefined to user interface
  • Milestone set to YAM 2.9p1
  • Owner set to damato
  • Status changed from pending to assigned

comment:4 Changed 7 months ago by damato

  • Status changed from assigned to pending

Sorry, but I tried hard to reproduce your problem. In addition, the crash logs you supplied doesn't point at some code where it makes sense that it crashes. So please try to reproduce the issue again and please try to use the latest nightly debug build (http://nightly.yam.ch/). Furthermore, please if you can catch a UTIL debug log (see http://yam.ch/wiki/FAQ/Debugging#BasicsaboutYAMsdebuggingfacilities for more information)

comment:5 Changed 7 months ago by Elwood

Fixed in 18-january version

comment:6 Changed 7 months ago by damato

  • Resolution set to invalid
  • Status changed from pending to closed

comment:7 follow-up: Changed 7 months ago by Elwood

Sorry no, I completely forgot I had to delete emails to trigger the bug :-(

So I still have crashes but only with the non-debug version!
If I use YAM.debug, I can delete many emails with no problems.

What can we do from here?

comment:8 in reply to: ↑ 7 Changed 7 months ago by damato

Replying to Elwood:

What can we do from here?

Well, there is actually little we can do as you seem to be the only person facing this problem right now. It is also strange that the debug version seems not to cause any problem for you. So the question remains what exactly triggers the problem. And as we (Thore and me) cannot reproduce your problems I wonder if you could first try to perform a complete new installation of YAM starting from the ground up and see if even a clean install causes crashes or if they are suddenly gone. So can you please try that?

comment:9 Changed 7 months ago by damato

  • Reporter changed from pferrucci@… to Elwood

Changed 7 months ago by Elwood

Crashloh with YAM.debug 2014-01-18

comment:10 follow-up: Changed 7 months ago by Elwood

I reported too fast last time :-(

I have the crash with debug or non debug versions. New crashlog attached with 18 january version.

Now that I see a lot of updates of MUI classes and YAM too, I'll update everything and report soon...

comment:11 Changed 7 months ago by tboeckel

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:12 Changed 7 months ago by tboeckel

  • Owner changed from damato to tboeckel
  • Status changed from reopened to assigned

comment:13 Changed 7 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7605]) * mui/HeaderList.c: added a NULL pointer check for the rare case that the list of header lines gets updated while the mail pointer is not yet valid. This closes #493.

comment:14 in reply to: ↑ 10 Changed 7 months ago by tboeckel

Replying to Elwood:

I have the crash with debug or non debug versions. New crashlog attached with 18 january version.

Please try again with the next nightly build. At least the crash should be fixed now, but make sure to take a look at the displayed Date: line. If it is missing then there is still something else going wrong.

comment:15 Changed 7 months ago by Elwood

I tried hard to reproduce it with version 30-jan-2014 but couldn't! Good job!

comment:16 Changed 5 months ago by damato

  • OS Platform set to All
  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Philippe Ferrucci(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)