close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

#499 closed bug (invalid)

Crash after recieving a mail.

Reported by: broadblues Owned by: tboeckel
Priority: high Milestone: YAM 2.9p1
Component: mail indexing Version: 2.9
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

This crash appears to come in two parts which may or mau not be directly related. First a message about YAM rendering on the wrong process pops up on the Workbench, then a GR occurs with AddPath() being the last but one entry in the stack.

Steps to reproduce

  1. Run YAM on it's own screen
  2. Go to workbench screen and wait for mail to arrive.
  3. The Message about rendering on the wrong process occurs
  4. The Grim reaper occurs just after the above has auto cleared.

I've only seen the GR after one of the rendering error messages, and these don;t occur everytime a mail is downloaded.

Expected results

A new mail is downloaded and added to incoming.

Actual results

The new mail disappears, ignoring the GR requires a reboot and so the mail is lost. I'm not yet sure whther it's dleted at the server side.

Attachments (3)

Crashlog_YAM thread [1]_2013-12-30_18-10-11.txt (3.9 KB) - added by broadblues 12 months ago.
Grim Reaper Log
Crashlog_YAM thread [2]_2013-12-31_10-49-19.txt (34.1 KB) - added by Raziel 12 months ago.
Same crash with different thread
MUI_Redraw() task mismatch_000.png (16.7 KB) - added by Raziel 11 months ago.
MUI_Redraw error

Download all attachments as: .zip

Change History (13)

Changed 12 months ago by broadblues

Grim Reaper Log

comment:1 Changed 12 months ago by broadblues

I just looked into my incomming folder to see what mails were there after the last occurance of this crash.
I see the following two mails, which are idenetical in all but name.

Q7V4aQAD98Y=.001,R 3528 ----rw-d Today 18:11:53
Q7V3zQAAdJk=.001,N 3528 ----rw-d Today 18:09:17

Only the later email is included in the index, and this later email was the mail downloaded imediatly after reboot. So it seems the mail is not deleted from the server has been downloaded and saved correctly but not added to the index file.

Changed 12 months ago by Raziel

Same crash with different thread

comment:2 Changed 12 months ago by Raziel

I can confirm this crash, just got it myself this morning.
Yam tried to download a mail, but was stuck with the "Checking mail from..." message in it's main window.

The mail was never downloaded.
I had to reset because CPU useage went up to 100% and draw the system unuseable.

The crash happened in another YAM thread, though

comment:3 Changed 12 months ago by damato

  • Milestone set to YAM 2.9p1
  • Owner set to tboeckel
  • Priority changed from undecided to high
  • Status changed from new to assigned

comment:4 Changed 11 months ago by Raziel

Now i lost a mail aswell.

The already mentioned crash came up again which i resumed in GrimReaper.

On (automatic through filter) moving that mail to it's subdir another crash happened.
(Something to do with "TransferMail")

I'm not sure if the mail was downloaded already (and on my HDD), at least i cannot find it.
It was deleted from the server though.

Unfortunately the system was already unstable so it did not save that crashlog.

If i ever get another chance, i'll try to save the second crashlog
(If you need it that is? I was told that after resuming one crash, a followup can't be trusted due to the system already being messed up?)

comment:5 Changed 11 months ago by Raziel

Mail found.

Index of Incoming wasn't updated after the second crash.
A reboot and new start of YAM brought the mail back.

Another tiny bit of information, albeit unrelated.
The crash happened with the (already per mail) reported MUI_Redraw error up front.

Changed 11 months ago by Raziel

MUI_Redraw error

comment:6 Changed 11 months ago by tboeckel

Please switch to YAM 2.10-dev for the time being to avoid this bug.

comment:7 Changed 11 months ago by tboeckel

(In [7577]) * tcp/pop3.c, tcp/smtp.c: added some checks for correctly resolved incoming and sent folders. This refs #499.

comment:8 Changed 11 months ago by tboeckel

Please try to reproduce this issue with the next nightly build. If mails are not received at all then please provide a FOLDER debug log created with the debug version.

comment:9 Changed 11 months ago by damato

  • Status changed from assigned to pending

comment:10 Changed 11 months ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Add Comment

Modify Ticket

Action
as closed The owner will remain tboeckel.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Andy Broad(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)