close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#505 closed bug (invalid)

multi assigm

Reported by: mc4834@… Owned by:
Priority: undecided Milestone: YAM 2.9p1
Component: charset handling Version: 2.9
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Amiga os 3.x, YAM 2.9

Since 2.9 upgrade multi assign doesn't work.
I have codesets.library installed in "path_to_dir", outside LIBS: and assigned with:
ASSIGN ADD LIBS: path_to_dir

Attachments (0)

Change History (6)

comment:1 Changed 11 months ago by tboeckel

What exactly is not working? Is it possible that you have another copy of codesets.library installed in any other path of you LIBS: assign?

comment:2 Changed 11 months ago by mc4834@…

The program fails to start.
With error message: prerequisite missing.
But, if I do (from CLI):
version codesets.library
it works. (6.5)
And it worked before, until the upgrade.

comment:3 Changed 11 months ago by tboeckel

Ok, and what about my question regarding possible multiple copies of codesets.library? Did you check every path the LIBS: assign points to?

Please note that with a multiassign only the very first version of a library will be found and used, no matter if further and more recent versions exist in other parts of LIBS:.

comment:4 follow-up: Changed 11 months ago by mc4834@…

No problems for that.
Just one installation of codesets.library is present.
During YAM upgrade (expert mode) I skipped codesets installation because it was yet installed.
Maybe I can try to upgrade to a previous version (2.7) to see if the problem was older...

comment:5 Changed 11 months ago by tboeckel

  • Milestone set to YAM 2.9p1
  • Resolution set to invalid
  • Status changed from new to closed

So this all happened because you implicitly forbade the installation of the new version, correct?

I will close this ticket then.

Version 0, edited 11 months ago by tboeckel (next)

comment:6 in reply to: ↑ 4 Changed 11 months ago by damato

Replying to mc4834@…:

No problems for that.
Just one installation of codesets.library is present.
During YAM upgrade (expert mode) I skipped codesets installation because it was yet installed.

Well, code sets.library was perhaps installed, but not in the correct version! YAM 2.9+ requires code sets.library version 6.16 to work. So please reinstall YAM 2.9 and DO NOT skip installation of any third-party component.

Maybe I can try to upgrade to a previous version (2.7) to see if the problem was older...

No, simply reinstall YAM 2.9 and install ALL third-party libraries as they are delivered by YAM.

In addition, your reported error message should have clearly stated that you need a newer version for YAM 2.9 to work!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • mc4834@…(Reporter, Participant)