close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

#514 closed bug (invalid)

YAM seems not use MUI's: Window positions are...

Reported by: rmsyam Owned by:
Priority: undecided Milestone: YAM 2.9p1
Component: undefined Version: 2.9
Severity: normal Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

I noticed that under MorphOS YAM seems not use correctely the setting in MUI: "Window positions are... If e.g. not stored is selected, resizing a window, keeps the resized position of it, even after a quitting and starting YAM. Not only size but also position!

Steps to reproduce

  1. open a write window
  2. change position and resize the window, then quit YAM and start again

Expected results

Actual results

Regression

Notes

Attachments (0)

Change History (1)

comment:1 Changed 11 months ago by damato

  • Milestone set to YAM 2.9p1
  • Resolution set to invalid
  • Status changed from new to closed

With YAM 2.9 we added a new possibility to directly configure within the YAM configuration if the window settings including the folder list and message list layout should be automatically saved upon exit of YAM. You can find this Option under Configuration -> Startup/Quit -> Save user interface layout (which is enabled per default).
The reason behind that option was, that we wanted to have a functionality to save the window position as well as the folder and message list layouts of the main window automatically when exiting YAM. In fact, we believe that is what most users actually want -> save the last state when leaving YAM.

Of course this option somehow interferes with the MUI own setting to define that the window position of a certain application should be automatically remembered or abandoned when exiting. So if you want to have the old behavior of MUI itself explicitly taking care of that you have to disable this option. But please keep in mind that you then always have to manually use the "MUI Snapshot" feature accessible through the drag bar of the main YAM window.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter)