close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 9 months ago

Closed 9 months ago

Last modified 7 months ago

#519 closed bug (fixed)

Addressbook images blacked out on MorphOS

Reported by: damato Owned by:
Priority: normal Milestone: YAM 2.9p1
Component: user interface Version: 2.8p1
Severity: blocker Keywords:
Cc: OS Platform: MorphOS
Blocked By: Blocking:
Release Notes:

fixed a bug which prevented the user images in the address book and mail information part of the read window from working on MorphOS.

Description

Summary

When downloading images via gravatar or manually choosing an image for an address book entry the image is just displayed black within the address book. The same happens when displaying these images within the header display in the read window.

Steps to reproduce

  1. create a new address book entry and assign it an email address which can be resolved via gravatar
  2. download image via gravatar or manually select one from disk.

Expected results

Image should be correctly displayed.

Actual results

No matter which image format is used the image in question is just displayed as a black image. However, as soon as a small image is used it seems to work fine. Thus, the image resizing mechanism seems to be involved here.

Attachments (0)

Change History (2)

comment:1 Changed 9 months ago by damato

  • Resolution set to fixed
  • Status changed from new to closed

(In [7619]) * mui/ImageArea.c: removed some workaround for some broken functionality in

MorphOS < 2.0 where the picture.datatype returned invalid data requiring
us to ignore the return values of these PDTM_SCALE calls. This caused the
image scaling to fail for newer MorphOS versions which should have
become more popular and widespread than these old variants. This
closes #519.

comment:2 Changed 7 months ago by damato

  • OS Platform set to MorphOS
  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Jens Maus(Reporter, Participant)