close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 8 months ago

Closed 8 months ago

Last modified 6 months ago

#520 closed bug (fixed)

Display name of folders should be editable

Reported by: damato Owned by:
Priority: normal Milestone: YAM 2.9p1
Component: user interface Version: 2.9
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

fixed a bug where the display name of standard mail folders (e.g. incoming) couldn't be changed.

Description

Summary

With YAM 2.9 a new folder system had been introduce. This included moving all folders to MailDir:Folders subdir. In addition users can't edit the default folder name and display name anymore. As it stands this seems to be somewhat too restrictive. Thus, users should be able to change the display name to their own needs. The folder directory name and path should be, however, not changeable.

Steps to reproduce

  1. double-click the incoming folder
  2. note that you can't edit the display name and folder directory name

Expected results

The display name should be editable while the folder directory name should be kept unchangeable.

Attachments (0)

Change History (2)

comment:1 Changed 8 months ago by damato

  • Resolution set to fixed
  • Status changed from new to closed

(In [7624]) * mui/FolderEditWindow.c: the display name of folders can now always be

changed to a user choice no matter which mail folder type it is. This
closes #520.

comment:2 Changed 6 months ago by damato

  • OS Platform set to All
  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Jens Maus(Reporter, Participant)