close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 months ago

Closed 7 weeks ago

#527 closed bug (invalid)

Replying to some mails leave To-field empty

Reported by: AmigaSurfer Owned by:
Priority: undecided Milestone: YAM 2.9p1
Component: mail filtering Version: nightly build
Severity: major Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Summary

At some mails the To-field leaves empty when replying

Steps to reproduce

  1. Open the mail
  2. Press reply

Expected results

To-field with sender

Actual results

To-field is empty

Regression

Notes

First seen at Nightly Build from 18.01.2014.
Still happens at Nightly Build from 29.01.2014.
Because this happens only on less mails, maybe already happens in an earlier version.

Attachments (2)

Reply-To Testmails.lha (6.6 KB) - added by AmigaSurfer 2 months ago.
Mails for testing Reply
pic00.png (24.3 KB) - added by tboeckel 8 weeks ago.
Screenshot of the folder settings

Download all attachments as: .zip

Change History (10)

Changed 2 months ago by AmigaSurfer

Mails for testing Reply

comment:1 Changed 2 months ago by tboeckel

I just tried both mails here on AmigaOS3/WinUAE and replying to them puts the correct address in the To field.

Did you try your modified test mails yourself?

comment:2 follow-up: Changed 2 months ago by AmigaSurfer

The modified test mails puts the correct address in the To field here, too.
Maybe the bug associated with the mailinglist setting of the folder and the address fields of the mail. See PM.

comment:3 Changed 8 weeks ago by tboeckel

This is the private mail of Frank:


Bei den geänderten Beispielmails wird bei mir jetzt auch der Absender
als neuer Empfänger übernommen. Das gleiche, wenn ich die orignial
Mails in einem anderen Ordner ohne Mailinglistenunterstützung
importiere. Hängt vielleicht mit der Mailinglistenunterstützung
zusammen. Ich habe mich eben auch gewundert, weshalb ich für einen
normalen Postfach-Ordner die Mailinglistenunterstützung aktiviert
habe. Aber das ist wohl die einzigste Möglichkeit, Mails aus
verschiedenen Ordnern heraus automatisch mit den entsprechenden
Absendern und Signaturen zu versehen.


Basically it seems that this issue is triggered by certain folder settings, in particular the mailling list support settings.

comment:4 in reply to: ↑ 2 Changed 8 weeks ago by tboeckel

Replying to AmigaSurfer:

The modified test mails puts the correct address in the To field here, too.
Maybe the bug associated with the mailinglist setting of the folder and the address fields of the mail. See PM.

Frank, is it ok for you when I attach your screenshot of the folder settings to this ticket?

comment:5 Changed 8 weeks ago by AmigaSurfer

Yes, it's ok.

Changed 8 weeks ago by tboeckel

Screenshot of the folder settings

comment:6 Changed 8 weeks ago by tboeckel

Now that I took another look at the screenshot I noticed that you are using the wrong receiver pattern. This is not your own address, but the address you must send posts to the mailling list to to let them appear on the list.

The "Auto detect" button will let YAM scan some mails in the folder to extract a common address pattern.

Personalized mails like the example mails are no mails from a mailing list and should not be treated as such.

comment:7 follow-up: Changed 7 weeks ago by AmigaSurfer

This is not a mailing list folder. It's a folder for personal mails from a specific account. I'm misusing the mailing list setting, to create all new mails and replies in this folder with the corresponding mail address of this specific account in the "From" field and with the corresponding signature as well.
I don't remember why I set my own email address in the receiver pattern field of all personal folders many many years ago. Maybe an earlier version of YAM required this to activate the mailing list support.
I cleared the receiver pattern field. Now all is working fine.

comment:8 in reply to: ↑ 7 Changed 7 weeks ago by tboeckel

  • Component changed from undefined to mail filtering
  • Milestone set to YAM 2.9p1
  • OS Platform changed from AmigaOS3 to All
  • Resolution set to invalid
  • Status changed from new to closed

Replying to AmigaSurfer:

This is not a mailing list folder. It's a folder for personal mails from a specific account. I'm misusing the mailing list setting, to create all new mails and replies in this folder with the corresponding mail address of this specific account in the "From" field and with the corresponding signature as well.

But exactly that's the point. You abused a feature for a purpose it was never intended for. Furthermore you left the "Destination address" (Zieladresse) field empty and got exactly the desired result: an empty To: field.

To sum it up: there is no bug to be fixed here.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Busse(Reporter, Participant)