close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 9 months ago

Closed 8 months ago

Last modified 8 months ago

#531 closed bug (fixed)

Crash selecting a mail with the Enter key

Reported by: samo79 Owned by:
Priority: normal Milestone: YAM 2.9p1
Component: foreign component Version: 2.9
Severity: major Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

In a clean YAM installation I was tested the import functionality, so i taked a fake mail as example and of course the importation goes ok, however when i try to open it (pressing Enter) YAM crashed

No problem instead tring to open it with a simple double click of the mouse

Consider that for this test i didn't configure YAM at all, so before trying to open the mail YAM of course will opened or atleast tried to open the prefs window

If you like to reproduce it, in attachment i will include:

  • A draft folder with a mail (as example)
  • A grab of YAM
  • The crashlog

Attachments (3)

Crashlog_YAM_2014-02-18_04-57-54.txt (29.0 KB) - added by samo79 9 months ago.
draft_folder.lha (823 bytes) - added by samo79 9 months ago.
grab.png (85.7 KB) - added by samo79 9 months ago.

Download all attachments as: .zip

Change History (7)

Changed 9 months ago by samo79

Changed 9 months ago by samo79

Changed 9 months ago by samo79

comment:1 Changed 8 months ago by damato

  • Milestone set to YAM 2.9p1
  • Priority changed from undecided to normal
  • Status changed from new to accepted
  • Version changed from nightly build to 2.9

I can perfectly reproduce the problem here on OS4. In fact, the following alternative step-by-step explanation will help to more easily reproduce the problem on any YAM installation:

  1. Make sure you have a mail in your drafts folder
  2. Go to the drafts folder select a mail and press 'Enter' to start an EditMail action
  3. Make sure YAM will show the requester in Config.c:IsValidConfig() by forcing valid=FALSE like:
--- Config.c	(revision 7749)
+++ Config.c	(working copy)
@@ -2854,6 +2854,7 @@
            firstSMTP->hostname[0] != '\0' &&
            firstPOP3->hostname[0] != '\0');
 
+  valid = FALSE;
   if(valid == FALSE)
   {
     DoMethod(G->App, MUIM_YAMApplication_OpenConfigWindow);
  1. Now with that change as soon as one uses the "Enter" key in the drafts folder to start an edit mail action a requester and the config window appears and as soon as the requester is acknowledged with 'Okay' a crashlog will be generated as posted above. If the mouse is used instead to double click a mail no crash happens and everything seems to work fine.

After some investigation it seems the cultrip might either within NList or even in MUI itself. To prevent the crash from happening one can do the following:

  1. Comment out the MUI_Request() call in Config.c:IsValidConfig()
  2. replace MUI_Request(G->App, ...) by MUI_Request(NULL, ...) and a normal EasyRequester will be generated instead which results in no crash at all.

So, Thore, can you please try to investigate if the cultrip is somewhere in MUI itself? Or at least try to reproduce it yourself first. At least this bug reports seems to be perfectly valid. Thus, scheduling it for 2.9p1.

comment:2 Changed 8 months ago by tboeckel

How do you end up with a mail in the Drafts folder, but without a valid config to create it beforehand? I don't want to declare this ticket as invalid. YAM should handle this situation definitely gracefully. But the way to prepare the prerequisits sounds very artificial.

comment:3 Changed 8 months ago by tboeckel

  • Component changed from user interface to foreign component
  • Resolution set to fixed
  • Status changed from accepted to closed

This is another ancient bug in MUI 3.9 and MUI 4 which gets triggered by calling the method MUIM_Application_NewInput in a recursive fashion like it happens when MUI_RequestA() is called as a reaction on a key press. The next MUI release will fix this crash.

comment:4 Changed 8 months ago by samo79

@Thore & damato

In a casual manner I just moved there the mail and so i discover the issue, however i admit it was a bit artificial as a test
Aniway guys thanks for the test and the fix !

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Samir Hawamdeh(Reporter, Participant)