close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#547 closed bug (invalid)

User guide won't open with Finnish locale

Reported by: marko.raina@… Owned by:
Priority: undecided Milestone:
Component: user interface Version: 2.9p1
Severity: major Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

YAM WWW user guide won't open if using Finnish locale. The web browser is trying to open a non-existing address http://yam.ch/wiki/fi:Documentation

Steps to reproduce

  1. Select menu Help-Contents

Expected results

As there is no Finnish web user guide yet, the browser should be directed to http://yam.ch/wiki/Documentation

Actual results

The browser is directed to non-existing http://yam.ch/wiki/fi:Documentation

Regression

Notes

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 6 months ago by AmigaPhil

This is because there is no Finish translation for the online doc yet.
Any help is welcome. ;-)

(I'm going to copy the English page for a start.)

comment:2 in reply to: ↑ 1 Changed 6 months ago by damato

  • Resolution set to invalid
  • Status changed from new to closed

Replying to AmigaPhil:

This is because there is no Finish translation for the online doc yet.
Any help is welcome. ;-)

Exactly. And there is nothing really I can do about that here. So it is the responsibility of each translator to make sure there exist a proper translated documentation (at least the entry page).

(I'm going to copy the English page for a start.)

Please refrain from doing that. As I said, each translator should do that on his own and it doesn't help if we now make hundreds of copies of the english entry page of the documentation available for each language. Each translator should do that and then start to translate. Otherwise they won't be motivated enough, I am afraid.

So closing this bug entry here than because the current behavior is completely valid and correct -> Go and create a translation !

comment:3 follow-up: Changed 6 months ago by AmigaPhil

Please refrain from doing that.

Already done, sorry.

I thought there should be at least the main page and the ARexxAPI page, because of the links from YAM interface.
But I understand your point of view. (Should I delete the newly created fi page ?)

comment:4 in reply to: ↑ 3 Changed 6 months ago by damato

Replying to AmigaPhil:

I thought there should be at least the main page and the ARexxAPI page, because of the links from YAM interface.
But I understand your point of view. (Should I delete the newly created fi page ?)

No, keep it for the time being. Hopefully many people will start translating the documentation as soon as they stepped onto the missing documentation page. Would be great to at least have a translated entry page to the documentation. At least with the functionality in the wiki we have the required functionality now!

comment:5 Changed 6 months ago by blmara

Thanks for quick reply. I still don't think it's a xxx language user's problem if one has updated the catalog translation for a program but hasn't started with much greater job (the guide translation). With the current system the user cannot (easily) use the manual of the program - and cannot understand why! I think the proper way to implement this is to route the user to the English manual pages if there is no xxx language translation of the manual yet.

Marko

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Marko Raina(Reporter, Participant)