close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 6 months ago

Closed 6 months ago

#550 closed enhancement (fixed)

mention the used filter in the logfile

Reported by: opiopi Owned by: tboeckel
Priority: normal Milestone: YAM 2.10
Component: mail filtering Version: 2.9p1
Severity: major Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Today i filter my incoming mails and some of them was moved to a wrong folder.
I seach which filter do the wrong movement but the log say nothing about the used filter
Therefore it would be very helpful if YAM could write the used filter into the logfile.
now such logfile line is e.g.:
1 Nachricht(en) aus dem Postfach 'Eingang' nach 'xxx' verschoben
and could be:
1 Nachricht(en) aus dem Postfach 'Eingang' mittels Filter 'xyz' nach 'xxx' verschoben

Attachments (0)

Change History (6)

comment:1 Changed 6 months ago by tboeckel

  • Milestone set to YAM 2.10
  • Owner set to tboeckel
  • Priority changed from undecided to normal
  • Status changed from new to assigned
  • Version set to 2.9p1

I will add a log entry for each moved mail. It will reference the filter name, the mail subject, the sender and the source and destination folder names.

comment:2 Changed 6 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

In 7814:

  • YAM_FI.c: moving a mail from one folder to another by a filter will now create a log entry in verbose mode including the filter which caused the move operation. This closes #550.

comment:3 Changed 6 months ago by opiopi

Now i get 2 nearly identical Entries in the log file, for my taste a little to much and logical not correct:
first entry with the prefix "Filter 'Filtername' hat " ... verschoben
second with exact the same text without the prefix.

Both say a mail is moved but in real really only one mail is moved.

comment:4 Changed 6 months ago by opiopi

i forget to mention the version:
YAM 2.10-dev (08.05.2014)
Copyright (C) 2000-2014 YAM Open Source Team [OS3/m68k, r7843]

comment:5 Changed 6 months ago by opiopi

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 6 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from reopened to closed

In 7848:

  • YAM_MA.c, misc: added an originator name for all mail movements. This name will be put into the verbose log for reference. In case the move was caused by a filter the filter's name will be used. This closes #550 again.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)