close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 8 months ago

Closed 8 months ago

#551 closed bug (fixed)

wrong icon info file in archive for 2.9p1 (os4)

Reported by: MichaelMerkel Owned by: tboeckel
Priority: normal Milestone: YAM 2.10
Component: installation Version: 2.9p1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

when you unarchive the new 2.9p1 archive to ramdisk and try to open the resources folder the amiga slows down for 2 seconds and then lists the content. except the "gallery" drawer and its icon. looking at it it is existing - but not recognized as icon it seems.

Steps to reproduce

  1. unarchive the 2.9p1 archive to ram
  2. try to open the ressources directory on workbench.

i checked the serial output with no luck. nothing is put to the line :-(
using a current os4 beta installation on the x1000.

Notes

see screenshot.

regards...
michael

Attachments (1)

GR_036.png (89.9 KB) - added by MichaelMerkel 8 months ago.
directory with icons. see the different look of the gallery icon.

Download all attachments as: .zip

Change History (6)

Changed 8 months ago by MichaelMerkel

directory with icons. see the different look of the gallery icon.

comment:1 Changed 8 months ago by damato

  • Component changed from undefined to installation
  • Milestone set to YAM 2.10
  • OS Platform changed from undefined to AmigaOS4
  • Priority changed from undecided to normal
  • Severity changed from major to minor
  • Status changed from new to accepted
  • Version set to 2.9p1

I can support that observation on OS4 here. I had more or less the same issue when I was preparing the release archive of 2.9p1 and found that when trying to view the content of the "Resources" folder using the Workbench the system stalled. I, however, suspected OS4 beta to be the problem. However, more investigation is certainly required. That's why I will flag this report as "accepted" and scheduled for 2.10.

comment:2 Changed 8 months ago by MichaelMerkel

i was informed by one person (matthias bachmann) who is no betatester and has the same problem.
maybe he can add a comment here if he reads it.
i sent him the link to this ticket.

thanks and regards...
michael

comment:3 follow-up: Changed 8 months ago by tboeckel

I think this is exactly the same issue we had with the latest MUI release (refer to http://muidev.de/ticket/22).

I snapshotted some icons for different systems with DOpus Magellan on my WinUAE setup and very obviously this system malforms the icon files in such a way that OS4 cannot handle them anymore afterwards.

The solution is very simple. We just have to replace the broken icon file with a new one.

comment:4 in reply to: ↑ 3 Changed 8 months ago by damato

Replying to tboeckel:

The solution is very simple. We just have to replace the broken icon file with a new one.

I already guessed that. However, it would also probably nice to fix the real root of the problem: no icon file whatsoever should result in the explained behavior here. So the responsible OS4 developer should probably look at these files and check what makes OS4 going wild just because of these files.

comment:5 Changed 8 months ago by tboeckel

  • Owner set to tboeckel
  • Resolution set to fixed
  • Status changed from accepted to closed

In 7827:

  • icons/os4: replaced the faulty Gallery drawer icon by a fixed one. This closes #551.

Add Comment

Modify Ticket

Action
as closed The owner will remain tboeckel.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Michael Merkel(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)