close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 7 months ago

Closed 7 months ago

#552 closed bug (fixed)

YAM failed returncode 10

Reported by: antibike Owned by: tboeckel
Priority: undecided Milestone: YAM 2.10
Component: translation Version: nightly build
Severity: major Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Summary

Die letzten Nightly Builds lassen sich nicht mehr starten. Es gibt nur den Rückgabewert 10.

Steps to reproduce

  1. run YAM

Expected results

YAM startet

Actual results

YAM failed returncode 10

Regression

Notes

Attachments (0)

Change History (2)

comment:1 Changed 7 months ago by tboeckel

  • Component changed from build environment to translation
  • Milestone set to YAM 2.10
  • OS Platform changed from MorphOS to All
  • Owner set to tboeckel
  • Status changed from new to assigned

Since YAM 2.9p1 is using UTF8 catalogs codesets.library is required when dealing with translated strings. Unfortunately there is a hen-and-egg problem when the found codesets.library does not meet YAM's minimum version requirements. In this case YAM will open a requester with no text at all, because it is unable to obtain translated strings.

If will change this to use at least the built-in english strings if codesets.library is not available or too old.

comment:2 Changed 7 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

In 7820:

  • YAM.c, Locale.c: fixed an empty error message in case codesets.library does not meet YAM's requirements but would be required for the translated error message. YAM will fall back to the built-in strings then. This closes #552.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Jürgen Lucas(Reporter)
  • Thore Böckelmann(Owner, Participant)