close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 7 months ago

Closed 7 months ago

#555 closed bug (fixed)

Problem with some reply address, when i try reply

Reported by: kaczus@… Owned by: tboeckel
Priority: undecided Milestone: YAM 2.10
Component: configuration Version: 2.9p1
Severity: major Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Summary

When I try reply e-mail on some e-mails sometimes receiver addres is not seen ( nothing in "To" gadget).
I don't know what is wrong, because headers emails looks properly.

Steps to reproduce

I can send an example e-mail, but not to the public view.

Expected results

Actual results

Regression

Notes

Attachments (1)

systemlog_yam.log (22.3 KB) - added by kaczus 7 months ago.
log with opened Yam and try Reply on one mail

Download all attachments as: .zip

Change History (18)

comment:1 follow-up: Changed 7 months ago by damato

Ok, as for the example email you can either replace all your private information in the email with some dummy information and attach it to that ticket or you can send it in private mail (the raw email file, zipped please) to thore and me.

comment:2 follow-up: Changed 7 months ago by tboeckel

Please also check the folder's settings. Perhaps the mail is located in a folder with active mailling list support but without a proper reply address.

comment:3 in reply to: ↑ 1 ; follow-ups: Changed 7 months ago by kaczus@…

Replying to damato:

Ok, as for the example email you can either replace all your private information in the email with some dummy information and attach it to that ticket or you can send it in private mail (the raw email file, zipped please) to thore and me.

Ok, where I can find these e-mails addresses?

comment:4 in reply to: ↑ 2 Changed 7 months ago by kaczus@…

Replying to tboeckel:

Please also check the folder's settings. Perhaps the mail is located in a folder with active mailling list support but without a proper reply address.

No, it is not a folder with active mailling list support. Some mails replay action work properly, some not.

comment:5 in reply to: ↑ 3 Changed 7 months ago by tboeckel

Replying to kaczus@…:

Ok, where I can find these e-mails addresses?

They are contained in each and every changelog file.

comment:6 in reply to: ↑ 3 Changed 7 months ago by damato

Replying to kaczus@…:

Replying to damato:

Ok, as for the example email you can either replace all your private information in the email with some dummy information and attach it to that ticket or you can send it in private mail (the raw email file, zipped please) to thore and me.

Ok, where I can find these e-mails addresses?

Send to: mail@… and tboeckel@…

comment:7 Changed 7 months ago by tboeckel

Both mails are correctly replied to here for me.

comment:8 Changed 7 months ago by kaczus@…

I analized when reply works properly. When in mail header there is Reply-to: or Cc: (and choose Sender and all Recipients) reply works properly. In other situation I have empty To: gadget.

comment:9 Changed 7 months ago by tboeckel

Please create a MAIL debug log created with the debug version of YAM when replying to such a faulty mail. Basics about the debug version can be found in the FAQ.

BTW: Please log in before commenting. If you have no login yet then it is time to get one.

Changed 7 months ago by kaczus

log with opened Yam and try Reply on one mail

comment:10 Changed 7 months ago by kaczus

Ok I've created debug log. I opened Yam, selected e-mail and clicked Reply button

Log looks like (full log in attachment):

00:D:        YAM_RE.c:940:content 'multipart/alternative; boundary="==o2.pl-WebMail-53924a3.3224b136.9f257=="' 
00:D:        YAM_RE.c:984:0 content type 'multipart/alternative' 
00:D:        YAM_RE.c:940:content 'text/plain; charset="UTF-8"' 
00:D:        YAM_RE.c:984:0 content type 'text/plain' 
00:D:        YAM_RE.c:940:content 'text/html; charset="UTF-8"' 
00:D:        YAM_RE.c:984:0 content type 'text/html' 
00:W:         qprintable.c:494:error while trying to convert qpdecoded string to local charset! 
00:W:         qprintable.c:494:error while trying to convert qpdecoded string to local charset!
Last edited 7 months ago by damato (previous) (diff)

comment:11 Changed 7 months ago by tboeckel

Very obviously you did not read the FAQ entry. You forgot to set ENV:yamdebug accordingly. Please enter setenv yamdebug mail file:path_to_log_file.txt in a Shell before running the debug version of YAM to create the log again.

Last edited 7 months ago by damato (previous) (diff)

comment:12 Changed 7 months ago by tboeckel

In 7835:

  • YAM_WR.c: added some debug output about the added recipients when replying to a mail. This refs #555.

comment:13 Changed 7 months ago by tboeckel

In 7843:

  • YAM_WR.c: added some more debug output for ticket #555.

comment:14 Changed 7 months ago by tboeckel

In 7871:

  • YAM_WR.c: when trying to find a suitable user identity when replying to a mail in a folder with active mailling list support the To: address must now be valid as well. This refs #555.

comment:15 Changed 7 months ago by tboeckel

  • Component changed from MIME handling to configuration
  • Milestone set to YAM 2.10
  • OS Platform changed from MorphOS to All
  • Owner set to tboeckel
  • Status changed from new to assigned

comment:16 Changed 7 months ago by tboeckel

In 7909:

  • mui/FolderEditWindow.c: restructured the safety checks before saving the folder's configuration. Especially the mailing list options have been reworked to avoid invalid settings which might cause problems later. This refs #555.

comment:17 Changed 7 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

After some private conversation it turned out that some folders had an invalid ML pattern (i.e. '#?') or an invalid empty destination address.

Replying to a mail in the Incoming folder will scan all folders for their mailing list support and will use these information of the first suitable folder. In this case the empty destination address together with the catch-all pattern caused YAM to leave the To: address of the reply mail empty.

My latest change will make sure that this situation cannot happen again. A yet desirable feature would be an automatic check for all folders when loading their configuration. The user should at least be prompted with a warning to check the folder configuration.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Thore Böckelmann(Owner, Participant)
  • Tomasz Kaczanowski(Reporter, Participant)