close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#557 closed bug (fixed)

HTML preview accents not correctly shown

Reported by: rmsyam Owned by:
Priority: normal Milestone: YAM 2.10
Component: foreign component Version: nightly build
Severity: major Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Summary

When displaying html attachment directly from within yam which opens OWB and shows the content, caracters with accents aren't shown correctly but are replaced by "?". The charset is ISO-8859-1 in yam. Now strange is, that when saving the same html attachment to ram and then displaying it in OWB, it is displayed correctly!

Steps to reproduce

  1. display the html attachment of the mail 2.

Expected results

Actual results

Regression

Notes

Attachments (3)

Fwd__RE__lieu_de_rencontre_du_4_juin_2014.eml (33.4 KB) - added by rmsyam 4 months ago.
windows-1258.txt (9.1 KB) - added by tboeckel 4 months ago.
Windows-1258 conversion table
Fwd__Catechese.eml (6.7 KB) - added by rmsyam 4 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 4 months ago by tboeckel

The reason is quite simple:

00:W: YAM_RE.c:1639:the specified codeset 'windows-1258' wasn't found in codesets.library

I really can't tell right now if codesets.library is just missing a (not so) well known codeset or if Windows-1258 is no valid codeset at all. But at least that is why you get the wrong characters.

comment:2 Changed 4 months ago by tboeckel

Oh, I just took a look at Thunderbird's codeset menu and Windows-1258 seems to be the Windows codeset for Vietnam. Not very common in western Europe...

comment:3 Changed 4 months ago by tboeckel

A possible solution without any code change is to supply a suitable conversion table in LIBS:charsets/windows-1258.txt. codesets.library will use that file for the conversion automatically if it exists.

Changed 4 months ago by tboeckel

Windows-1258 conversion table

comment:4 Changed 4 months ago by tboeckel

  • Component changed from undefined to foreign component
  • Milestone set to YAM 2.10
  • OS Platform changed from MorphOS to All
  • Priority changed from undecided to normal
  • Resolution set to fixed
  • Status changed from new to closed

Just use the attached conversion table. For me the mail is displayed correctly then.

comment:5 follow-up: Changed 4 months ago by rmsyam

Yes, thanks, this confersion table does correct the problem! Perhaps it would be a good idea to add it also for next codeset archive.

But I do have another one here, also e-mail received from somebody in which there are accented caracters replaced by ?. But this time, the problem seems only shown in YAM, when opening the html part in OWB it gets displayed correctly. I attach the mail.

Changed 4 months ago by rmsyam

comment:6 in reply to: ↑ 5 Changed 4 months ago by tboeckel

Replying to rmsyam:

Yes, thanks, this confersion table does correct the problem! Perhaps it would be a good idea to add it also for next codeset archive.

I committed that table already along with some other Windows-125x tables.

But I do have another one here, also e-mail received from somebody in which there are accented caracters replaced by ?. But this time, the problem seems only shown in YAM, when opening the html part in OWB it gets displayed correctly. I attach the mail.

This mail show exactly the same problem as the example mail of #432. There are two alternative text and HTML part which both claim to be UTF8 encoded. While this is true for the HTML part the plain text part seems to be Windows-1251 encoded, but definitely not UTF8. YAM will then try to convert this wrong UTF8 encoded text back to ISO-8859-1 which of course must fail. Hence you get the ? characters.

There is nothing we can do about this, because it is a fault of the sending mail client.

comment:7 Changed 4 months ago by rmsyam

Ok, understood! Thanks for having checked.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter, Participant)