close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 months ago

Closed 2 months ago

#561 closed bug (fixed)

automatic mail check not working in nightly?!

Reported by: MichaelMerkel Owned by: tboeckel
Priority: normal Milestone: YAM 2.10
Component: TCP/IP interface Version: nightly build
Severity: major Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

I use the current (latest) nightly 20.6185 (r3383).
i have YAM iconified and know that there is one mail on the server. server settings are set to check each minute. but yam does not check... i waited and watched the icon on screen - does not work.

Steps to reproduce

  1. start yam
  2. configure auto mail check on a server
  3. wait...

don't know since when this is no longer working here...
i use os4.1 beta on a X1000 - maybe the bug lies there?

regards...
michael

Attachments (1)

YAM_debuglog.txt (26.5 KB) - added by MichaelMerkel 2 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 in reply to: ↑ description Changed 2 months ago by tboeckel

  • Component changed from undefined to TCP/IP interface
  • Milestone set to YAM 2.10
  • OS Platform changed from undefined to AmigaOS4
  • Priority changed from undecided to normal
  • Status changed from new to accepted

comment:2 Changed 2 months ago by tboeckel

In 7881:

  • Timer.c, YAM_MA.c: added some debug output to the automatic POP3 download. This refs #561.

comment:3 in reply to: ↑ description ; follow-ups: Changed 2 months ago by tboeckel

Replying to MichaelMerkel:

I use the current (latest) nightly 20.6185 (r3383).

Please don't use terms like "latest" but use exact dates instead, because "latest" will be impossible to determine in a few weeks with some further nightly builds inbetween. And the version number is the one of MUI, not the one of YAM...

i have YAM iconified and know that there is one mail on the server. server settings are set to check each minute. but yam does not check... i waited and watched the icon on screen - does not work.

Create a TIMER+NET debug log using the debug version of YAM. That will show which timer expires when and how far the download process gets.

comment:4 in reply to: ↑ 3 Changed 2 months ago by MichaelMerkel

Replying to tboeckel:

Replying to MichaelMerkel:

I use the current (latest) nightly 20.6185 (r3383).

Please don't use terms like "latest" but use exact dates instead, because "latest" will be impossible to determine in a few weeks with some further nightly builds inbetween.

really no need to tell me. as you see i tried to add the version but unfortunately grabbed the mui version string :-/

And the version number is the one of MUI, not the one of YAM...

sorry for that.

regards...
michael

comment:5 in reply to: ↑ 3 Changed 2 months ago by MichaelMerkel

Replying to tboeckel:

Replying to MichaelMerkel:

...

Create a TIMER+NET debug log using the debug version of YAM. That will show which timer expires when and how far the download process gets.

here it comes with latest nightly from tonight (build 20140511).

thanks and regards
michael

Changed 2 months ago by MichaelMerkel

comment:6 Changed 2 months ago by tboeckel

  • Owner set to tboeckel
  • Resolution set to fixed
  • Status changed from accepted to closed

In 7932:

  • Timer.c: fixed the not processed POP3 timers in case two or more timer events were handled within one loop. This closes #561.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Michael Merkel(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)