close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 5 months ago

Closed 4 months ago

Last modified 4 months ago

#574 closed bug (worksforme)

smtp send on port 587 impossible ?

Reported by: voxel Owned by:
Priority: undecided Milestone:
Component: TCP/IP interface Version: 2.9p1
Severity: major Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

using a protected smtp port isn't possible with yam 2.9p1, when trying to send throught this port 587 on my ovh account I ever get the response "the smtp server isn't responding, or does not support smtp"

Steps to reproduce

  1. edit a message that shopuld be sent throught a protected smtp port 587 via login + password,
  2. press "send"

Expected results

message sent to the remote address

Actual results

after a while error message "smtp isn't responding, or doesn't support smtp"

Regression

Notes

use of this protected smtp WORKS like a charm when using thunderbird on windows, and yam preferences are set the same as thunderbird ones so it should definitelly be a yam problem.

Attachments (0)

Change History (6)

comment:1 Changed 5 months ago by damato

  • Status changed from new to pending

Please provide some debug output. Either download the debug version of YAM 2.9p1 and execute the following command in a command shell:

setenv yamdebug all,stdout

then run YAM from the same command shell and catch the debug output until SMTP transfer doesn't work.

Or you take the normal version of YAM and run it from a command shell with the "DEBUG" argument so that it will output the TCP/IP traffic in the same command shell. Then attach your debug output here so that we can investigate. Make sure that none of your debug output contains any private information before attaching it here.

comment:2 follow-up: Changed 5 months ago by voxel

here isb the ouput from yam2.9p1 with "DEBUG" when attempting to send a mail in this case :

SERVER[0071]: 220 ns0.ovh.net ssl0.ovh.net. You connect to mail431.ha.ovh.net ESMTP
CLIENT[0018]: EHLO [127.0.0.1]
SERVER[0065]: 250-ns0.ovh.net ssl0.ovh.net. You connect to mail431.ha.ovh.net
SERVER[0022]: 250-AUTH LOGIN PLAIN
SERVER[0022]: 250-AUTH=LOGIN PLAIN
SERVER[0016]: 250-PIPELINING
SERVER[0014]: 250-8BITMIME
SERVER[0020]: 250 SIZE 109000000
CLIENT[0012]: AUTH LOGIN
SERVER[0018]: 334 blablablablabla
CLIENT[0034]: dmblablablablablablablablablab=
SERVER[0018]: 334 blablablabla
CLIENT[0014]: dmblablabl==
SERVER[0035]: 535 authorization failed (#5.7.0)

what's wrong ??

Last edited 5 months ago by damato (previous) (diff)

comment:3 in reply to: ↑ 2 Changed 4 months ago by damato

Replying to voxel:

what's wrong ??

Well that's hard to say. Just from the debug output I would say either the user name or the password you supplied in YAM is wrong. However, to investigate this issue further I would propose you download the debug version of YAM 2.9p1 (see Download link above) and the run the following command in a command shell:

setenv yamdebug net,stdout

Then start YAM from the same command shell and catch the debug output. Or you use the following command:

setenv yamdebug net,file:ram:t/debuglog.txt

Then attach this debug output here. And if this doesn't help you can also (if you trust me) send me your login name and password for that smtp account so that I can run some basic tests and see where YAM might have a problem.

In addition you can download one of the latest nightly build of 2.10-dev and see if you also have the same problem with that version.

Last edited 4 months ago by damato (previous) (diff)

comment:4 follow-up: Changed 4 months ago by voxel

Well, tryied with both debug versions 2.9p1 and 2.10, it was still not working.

so I've changed the smtp password at my server and entered the new one in yam2.10 so now pop3 and smtp passwords are different and that worked !
I can receive mails as before and send new ones throught my protected smtp server. Thanks for the help.

BTW, I found that when exiting yam2.10b by clicking the close button I'm systematiquely get a DSI grimripper requester... btw, as this happens on a betatester x1000 I can't post the crashlog there as it is an open forum. if you're x1000 betatester yourself send me your ID privately and I'll send you the crashlog.

comment:5 in reply to: ↑ 4 Changed 4 months ago by damato

  • Resolution set to worksforme
  • Status changed from pending to closed

Replying to voxel:

Well, tryied with both debug versions 2.9p1 and 2.10, it was still not working.

so I've changed the smtp password at my server and entered the new one in yam2.10 so now pop3 and smtp passwords are different and that worked !
I can receive mails as before and send new ones throught my protected smtp server. Thanks for the help.

Well, good to hear that it works now. However, I am still curious to see/find out what was/is the actual reason why it wasn't accepting the password as there might still be a hidden bug in YAM which only comes up with the password you have chosen. So please change the password back to the old one and try again. If it still fails please use the debug version again and produce a debug log which you can send to us so that we can investigate if there is a problem in YAM or not. Until you provide that information I will flag this ticket as "worksforme" because you didn't provide all necessary information for us to analyze.

BTW, I found that when exiting yam2.10b by clicking the close button I'm systematiquely get a DSI grimripper requester... btw, as this happens on a betatester x1000 I can't post the crashlog there as it is an open forum. if you're x1000 betatester yourself send me your ID privately and I'll send you the crash log.

I am actually an OS4 developers, so feel free to send it to me. However, please don't continue to report/discuss this problem in here but open a new ticket. For every new problem a new ticket should be opened.

comment:6 Changed 4 months ago by damato

  • Reporter changed from voxel@… to voxel

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Jean-François Bachelet(Reporter, Participant)