close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 3 months ago

Closed 3 months ago

Last modified 2 months ago

#575 closed bug (duplicate)

I am getting a message about failing to initialize TLSv1/SSLv3 when I try to get mail

Reported by: tlm@… Owned by:
Priority: normal Milestone: YAM 2.10
Component: TCP/IP interface Version: 2.9p1
Severity: major Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

Steps to reproduce

1.Get mail
2.

Expected results

connect to server and downloaad mail

Actual results

Message shown above

Regression

Notes

My POP3 mail server guys tells me that he just updated the certificates on his server. This was required by the people who generate certificates. That's when my problem started. I think I need to update the certs in the cert directory of YAM but don't know how to do that.

Attachments (1)

debuglog.txt (25.2 KB) - added by tlm@… 3 months ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 3 months ago by tboeckel

  • Milestone set to YAM 2.10
  • Priority changed from undecided to normal
  • Resolution set to duplicate
  • Status changed from new to closed

This issue is very probably exactly the same as #530. Please refer to this ticket.

The nightly builds of YAM are distributed with more recent certificates than the 2.9 release. Just copy the ca-bundle.crt over your installed version in the resources/certificates directory.

comment:2 Changed 3 months ago by damato

As you are using AmigOS4 I think there is a probability that you are not affected by #530 but have a different problem. To better investigate this problem please download the debug version of YAM 2.9p1 and execute the following command in a command shell:

setenv yamdebug net,file:ram:t/debuglog.txt

then run YAM and your tests again and please attach debuglog.txt to this ticket (after having stripped any private information) so that we can investigate the real reason.

In addition you can download an updated ca-bundle.crt from https://yam.ch/export/HEAD/trunk/resources/certificates/ca-bundle.crt

and store it into PROGDIR:Resources/Certificates.

Changed 3 months ago by tlm@…

comment:3 Changed 2 months ago by damato

Thanks for the debug log. It clearly points out that this is indeed a different issue than the main one explained in #530. In fact, it is a duplicate of #559 which, however, have been already fixed since a while.

So please wait until YAM 2.10 had been released or (as a workaround) download the latest nightly build and use that instead because the latest nightly builds contain fixes for the problem described there.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • tlm@…(Reporter)