close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 months ago

Closed 2 months ago

#577 closed bug (fixed)

Fetching mails only on second step

Reported by: papaoskar Owned by: tboeckel
Priority: normal Milestone: YAM 2.10
Component: TCP/IP interface Version: nightly build
Severity: major Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

Fetching mails only on second step

Steps to reproduce

  1. Start YAM210dev and the download should start as it did before. If you then klick on "Holen" the mails are downloaded.
  1. When YAM is started the transfer window opens all accounts and tries to download.

But on ervery acoount is shown nothing to download. When you then a second later klick on download every mail on every account is downloaded.

Expected results

Actual results

Regression

Notes

System here is AmigaOne X1000

Attachments (1)

sashimi.out (28.1 KB) - added by papaoskar 2 months ago.
Output when starting YAM debug

Download all attachments as: .zip

Change History (7)

comment:1 Changed 2 months ago by tboeckel

Please start YAM from a shell with the "DEBUG" option. This will print out all network trafic to the shell, including the number of mails waiting on the server. Please attach that output to this ticket, but make sure to strip any private data before.

Changed 2 months ago by papaoskar

Output when starting YAM debug

comment:2 Changed 2 months ago by papaoskar

The interesting lines of sashimi output seem to be Nr. 259 to 270.

comment:3 Changed 2 months ago by tboeckel

This is not exactly the log I asked for. But at least the log clearly shows that there are no mails available for download. So YAM's reaction is correct.

You can create a second log by starting the non-debug build from a shell like "YAM debug". This is different from starting the debug build.

For a third log you must again use the debug build and set ENV:yamdebug to "NET" before starting it.

Jens, we really should rename that DEBUG option to something else to avoid this kind of confusion in the future.

comment:4 Changed 2 months ago by tboeckel

  • Component changed from user interface to TCP/IP interface
  • Milestone set to YAM 2.10
  • Owner set to tboeckel
  • Priority changed from undecided to normal
  • Status changed from new to assigned

I was just able to reproduce this issue myself. I will see what is the cause.

comment:5 Changed 2 months ago by tboeckel

In 8196:

  • tcp/pop3.c, tcp/pop3.c, tcp/smtp.c: the answer to POP3/SMTP command received from the server is now included in the NET debug log. This refs #577.

comment:6 Changed 2 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

In 8197:

  • tcp/pop3.h: fixed a wrong flag definition which caused the automatic mail download upon startup to be treated as a connection test which does not download any mails by intention. This closes #577.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Dr. Heiko Pollmeier(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)