close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 5 years ago

Closed 15 months ago

Last modified 15 months ago

#81 closed enhancement (wontfix)

Notification for hided MIME parts...

Reported by: stevebow@… Owned by:
Priority: low Milestone:
Component: user interface Version:
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by damato)

The attached message is a HTML message that YAM 2.5-dev-20061108 [OS4/PPC] won't display. Even with "Convert viewable HTML message parts to plain text" unchecked, the message is still not displayed nor is there any attachment icon.


Moved from SF:
https://sourceforge.net/tracker/?func=detail&aid=1593279&group_id=13560&atid=363560

Attachments (1)

HTML_msg.lha (3.2 KB) - added by damato 5 years ago.
Example HTML message - Moved from SF. Original author: stevebow

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by damato

Example HTML message - Moved from SF. Original author: stevebow

comment:1 Changed 5 years ago by damato

As already pointed out in an email, this particular is more than broken. It first uses an "big5" charset definition which doesn't exist at all. And then also the alternative "test/plain" MIME part is completly empty which break the RFC for "multipart/alternative"

Sorry, but there is no way and reason wor workaround such broken emails., especially if they SPAM mails like that one.


Moved from SF. Original poster: damato

comment:2 Changed 5 years ago by damato

Oh, FFS, I told you in the ML it's not spam. It is an announcement ML I am on.

The issue /really/ here - as was mentioned in the ML - is that there is no notification by YAM that it is not displaying a broken message. How about a requester pop up as does happen with broken uuencoded messages instead? I am not asking for YAM to work around such broken e-mails, that is ridiculous, the combinations of malformations would keep you busy forever! A notification would alert the user to a problem, so that person may use the Display Message function instead if they choose.

Should I open a new feature request or reopen this one as a feature request? Hint hint.


Moved from SF. Original poster: stevebow

comment:3 Changed 5 years ago by damato

  • Component changed from nightly build to stable build
  • Type changed from bug to enhancement
  • Version 2.5 deleted

Well, the problem is, YAM doesn't know and can't find out that the mail is broken. Syntactically (looking at the MIME structuring) the mail is perfectly fine - but it's content is what I would say "broken". So there is no real way in analyzing the content as that would slow down YAM dramatically. the only chance I see to notify the user is to show some kind of notification to the user that the mail contains some hidden alternative parts.

So I will move that ticket to the feature tracker requesting such a notification possibility.


Moved from SF. Original poster: damato

comment:4 Changed 5 years ago by damato

  • Component changed from stable build to undefined

comment:5 Changed 5 years ago by damato

  • Cc yamos-svn@… removed

comment:6 Changed 20 months ago by damato

  • Component changed from undefined to user interface
  • Description modified (diff)
  • Milestone set to YAM 2.9
  • Priority changed from undecided to low
  • Status changed from new to accepted

comment:7 Changed 15 months ago by damato

  • Resolution set to wontfix
  • Status changed from accepted to closed

After having discussed the matter with Thore we feel such a notification is not possible and that the currently implemented functionality on how to identify that there are some hidden parts are sufficient in YAM 2.8+.

comment:8 Changed 15 months ago by damato

  • Milestone YAM 2.9 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • stevebow@…(Reporter)