close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 12 months ago

Last modified 7 months ago

#9 closed bug (fixed)

Wrong UTF-8 Support

Reported by: opiopi Owned by: damato
Priority: normal Milestone: YAM 2.9
Component: charset handling Version: 2.5
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed a problem where YAM was unable to create properly UTF-8 encoded emails.

Description (last modified by damato)

Hi Develoers

I think YAM does not support the UTF-8 encoding correct.

Here is a Step by Step example:

  1. Write a new Mail (Type and To and Subject).
  2. Switch to the Options Tab.
  3. Select UTF-8 as Charset.
  4. Switch back to the Message Tab.
  5. Type some non ASCII Letters (e.g. the Euro Sign and ��� ��� �).
  6. Click "Hold".
  7. Switch to the Outguing Folder.
  8. Select the Mail you just wrote.
  9. Click Read in the Toolbar.
  10. Look at the Content-Type it's text/plain; charset=UTF-8 11. But in the Mail you see "? ? ???" but it should "� ��� ��� �"

The cause it that YAM does not encode the Mail to UTF-8 if you click on the "Hold" Button. If you then open the Mail for Read YAM seems to try to decode the UTF-8 Mail but can't find any UTF-8 sequence and you see the question marks.

Hope anybody can fix that...

TIA

Best Regards Frank (Opi) Weber


Moved from SF:
https://sourceforge.net/tracker/?func=detail&aid=2084854&group_id=13560&atid=113560

Attachments (0)

Change History (14)

comment:1 Changed 4 years ago by damato

  • Description modified (diff)

comment:2 Changed 4 years ago by damato

This is not really a bug, but more or less a not yet completed feature.

We introduced the modifyable character set for writing new mails recently only for the purpose to fake the character set of an outgoing mail. That means you can type you mail as usual (most probably using some kind of eastern european characters) and set the charset to something like ISO-8859-42, at least anything different than ISO-8859-1, which AmigaOS uses by default. The receiver of the mail will then be able to read the mail properly. But YAM does NO reencoding of the mail corresponding to the new charset. Only the charset information in the mail's headers will be adopted.


Moved from SF. Original poster: thboeckel
While this works quite good for any Latin-1-alike charset UTF8 is the big exception from the rule as it requires special character sequences to be decoded correctly. Since YAM doesn't do any reencoding when changing the charset the necessary sequences are missing. When YAM then later tries to decode the mail it will try to convert the falsely UTF8 characters back to Latin-1, and of course must fail to find suitable replacement characters. Hence question marks will be produced.

An "quick'n'easy" fix for this issue would be to exclude UTF8 from the list of charsets for writing mails. The complete fix would be to make YAM *and* TE.mcc able to handle arbitrary charsets, or even better completely switch to UTF8 internally.

comment:3 Changed 4 years ago by damato

  • Priority changed from major to undecided
  • Severity set to major

comment:4 Changed 4 years ago by damato

  • Component changed from nightly build to charset handling

comment:5 Changed 4 years ago by damato

  • Cc yamos-svn@… removed

comment:6 Changed 4 years ago by damato

  • Milestone set to YAM 2.7
  • Priority changed from undecided to normal
  • Reporter changed from opiopi@… to Opi
  • Status changed from new to accepted

comment:7 Changed 4 years ago by damato

  • Reporter changed from Opi to opiopi

comment:8 Changed 3 years ago by damato

  • Description modified (diff)
  • Milestone changed from YAM 2.7 to YAM 2.8

comment:9 Changed 20 months ago by damato

  • Milestone changed from YAM 2.8 to YAM 2.9

comment:10 Changed 13 months ago by damato

  • Owner changed from somebody to damato
  • Status changed from accepted to assigned

comment:11 Changed 12 months ago by damato

  • Description modified (diff)

comment:12 Changed 12 months ago by damato

  • Resolution set to fixed
  • Status changed from assigned to closed

In [6877]) * mui/WriteWindow.c: change SaveToFile uses to actually convert the entered

text to the target charset selected in the write window. This should fix
problems when trying to generate/send UTF8 encoded mails as they were
written to the temp file of the write window with the read encoding always.
Now YAM will compare the configured read and write charset and if they are
different a charset conversion via SaveToFile will be performed. This
hopefully fix a long standing bug and closes #9.

  • mui/MailTextEdit.c: added charset conversion functionality to LoadFromFile and SaveToFile methods which will allow to save the currently displayed mail text in a specific target charset.

comment:13 Changed 10 months ago by tboeckel

(In [7112]) * YAM_WR.c, mui/WriteWindow.c: all header lines are encoded using the configured or dynamically set write charset. This finally makes it possible to compose proper UTF8 encoded mails and refs #9.

comment:14 Changed 7 months ago by damato

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter)
  • Jens Maus(Owner, Participant)