close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 19 months ago

Last modified 13 months ago

#94 closed enhancement (duplicate)

Add "Abort" toolbar-button to stop filtering in progress

Reported by: amigalex@… Owned by:
Priority: undecided Milestone:
Component: undefined Version:
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by damato)

In some case it is desirable to abort filtering, like when a filter wasn't set right and starts moving 1000's of messages to another folder...


Moved from SF:
https://sourceforge.net/tracker/?func=detail&aid=1810651&group_id=13560&atid=363560

Attachments (1)

02h13m36s.png (83.7 KB) - added by damato 4 years ago.
yam gui snapshot - Moved from SF. Original author: amigalex

Download all attachments as: .zip

Change History (8)

comment:1 Changed 4 years ago by damato

This already possible for some time with the nightly builds. While filtering is in progress you get a progress bar in the status bar with an "X" button on the right side. Just press the "X" to abort the filter process. Of course that requires the status/info bar to be active. If haven't done so, then please activate it in the config window on the Look&Feel page.


Moved from SF. Original poster: thboeckel

comment:2 Changed 4 years ago by damato

Actually I disabled it on purpose...

I like the GUI clean and simple, the same way it was with 2.3p, so I don't use the status bar, preview pane, and search field. (see atachment) Besides, I already have the selected folder and unread/total messages info from the list on the left...

An alternative would be to open a progress window with just the gauge gadget and "stop" button if A: the status bar is disabled, and B: the total number of messages to be filtered is over a certain treshold. There's probably no point in opening a progress window for less than 20 messages as it would finish too fast to read or react.


Moved from SF. Original poster: amigalex

Changed 4 years ago by damato

yam gui snapshot - Moved from SF. Original author: amigalex

comment:3 Changed 4 years ago by damato

IMHO an additional progress window will be too much. However, we already have plans to add a dynamic "Stop" toolbar button as soon as there is something to abort. Unfortunately this have to wait until we start working on YAM 2.6. Until that happens you might want to turn the status bar back on as otherwise you won't have any chance to abort e.g. the filtering, I am afraid.


Moved from SF. Original poster: damato

comment:4 Changed 4 years ago by damato

  • Component changed from stable build to undefined

comment:5 Changed 4 years ago by damato

  • Cc yamos-svn@… removed

comment:6 Changed 19 months ago by damato

  • Description modified (diff)
  • Milestone set to YAM 2.9
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #134

comment:7 Changed 13 months ago by damato

  • Milestone YAM 2.9 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • amigalex@…(Reporter)