wiki:FAQ/General Questions

Version 5 (modified by damato, 3 years ago) (diff)

--

FAQ Contents

    Error: No page matching General Questions found
    Error: No page matching Installing YAM found
    Error: No page matching Using YAM found
    Error: No page matching ARexx scripting found

General Questions

Are there any chances to see YAM being ported to other GUI systems such as Reaction?

Even if it would be a nice opportunity for YAM to be available for other GUI systems than just MUI, chances are more or less zero to see it ever be ported to something that isn't at least compatible or derived from MUI. Not only would it take a very large amount of time to adapt it to other GUI systems, which in fact would certainly end up in a complete rewrite from scratch, but there doesn't exist any other GUI system on AmigaOS which is as feature rich and flexible as MUI.

Even the advanced Reaction classes supplied with AmigaOS4 won't allow to convert all current functionality in YAM over to a Reaction GUI. And then, YAM uses numerous third-party MUI custom classes such as TextEditor.mcc, NList.mcc and so on which are not or only partly available as e.g. Reaction classes. In addition, MUI is so flexible that you can very easily tune its look&feel to be pretty much the same like the GUI system you normally use. And another point is that all current Amiga platforms come with at least a MUI compatible GUI toolkit (AmigOS3, AmigaOS4, MorphOS, AROS) so that YAM can be very easily maintained as a multi-platform email program by just using MUI.

So we currently don't really see a possibility or reason to port YAM to any other GUI system available to AmigaOS-based computer systems. MUI is still the most advanced, flexible and available GUI toolkit for any Amiga platform.

Why does YAM complain about a wrong version of a MUI custom class (e.g. NList.mcc)?

Either the installer script didn't update the MUI libraries properly, or there is still an old version loaded in the memory or somewhere on your hard disk. Try rebooting your Amiga; if this doesn't help, copy the contents of the MUI directory from the YAM archive to 'MUI:libs/mui'.

Please also make sure you don't have a 'YAM:Libs' or 'YAM:mui/libs' directory in which old MUI classes are stored. The only path were #?.mcc and #?.mcp files belong is 'MUI:libs/mui'.

(How) can I access an IMAP mail server from YAM?

Unfortunately, YAM isn't currently able to access mail servers that do only support IMAP as the mail access protocol. Up to now, YAM only supports the POP3 protocol for downloading/retrieving emails from a mail server. But we have already considered supporting IMAP in a future version of YAM. According to our roadmap we have planned to support IMAP presumably in version 3.0+.

However, for current versions of YAM, there might be chances that the IMAP server you want to get the mail from also supports the POP3 protocol. Either your provider also allows POP3 downloads or the IMAP server software itself is able to manage the POP3 protocol directly. Please consult your provider for more details.

Can I use YAM to read newsgroups from the Usenet?

YAM doesn't support newsgroups (NNTP) and it's not planned to implement this in a later version. If you're looking for a newsreader, have a look at NewsRog or any similar Usenet client.